Ingress 2.39.3 Release Notes



  • I have never had my device rooted or Magisk installed. And it worked just fine before that Update. I wonder why it takes so much time for the game to show me the message... checking safetynet or the storage is propably done at startup, but the message pops up like about 30 or more seconds after that.

  • What OS are you using? It booted up for me fine on iOS

  • royalravenroyalraven ✭✭
    edited February 2020

    AH what is going on with "Ingress is not supported on this device configuration"! I'm not rooted nor have installed SuperSU or Magisk. Straight up clean. Worked yesterday, my phone grabbed the latest version in the App Store today and I'm getting booted out within minutes. Going back to a prior version. Totally wasted hours trying to troubleshoot this to come to the conclusion that its the newest version.

  • I don't have TWRP, nothing to delete. Google Pay, banking apps, PoGo are working, SafetyNet passes - just Prime exits randomly.

  • Currently Android 10 with the 1st November 2019 security update as the most recent although I know there's newer ones available they are not coming down the official system update downloader.

    Install of the ingress app is ok and no problem there but upon start as I mentioned it doesn't load the globe logon animation and skip straight to what should be the map but it's all black with two local portal names like a mission badge layered on top of each other.

    This link is what started happening after the last update and the umbra deploy event stat got added and I got my first badge,the app just then went crazy...I waited until this update 2.39.3 came out to update and hopefully repair the installed version but it's not and just updated the crashed version so I suspect the Devs need to get involved to find out the source of these bugs with us there users and community and not to ignore us as without there player base there games and bank balances won't thrive.

  • edited February 2020

    Hey there .Have you tried the basic troubleshooting steps? It is not clear from your post.

    So common i am afraid but so basic

    1.delete app cache

    2.delete app data


    4.Turn your phone off

    5.Turn your phone on

    6.Re install the application

    7.install if possible of course on another available phone just to check

    Thanks a priori

    Post edited by aristogeiton1 on
  • In my case, Prime did not work normally due to the fact that it found the twrp archive, which was used several months ago to change the phone firmware from the native miui to aosp.

    We all know that Prime is much more demanding on the phone resources than the old Scanner. Therefore, changing the phone firmware to less resource-intensive was easier than changing the phone to a newer one.

    Prime’s system requirements do not indicate that it cannot work on non-stock phone firmware. Therefore, it is not entirely clear why devices on which firmware has been changed at least once using twrp (often this is the only way to change the firmware) become unsupported.

  • edited February 2020

    Have you tried what yoptman suggested ?Any folders present on you device that triggers the issue? TWRP or such? Any archive files of such apps? Remainings that should have been deleted? You said that your device is not rooted so you are ok with the ToS.

  • royalravenroyalraven ✭✭
    edited February 2020

    Probably the one thing I haven't tried because it seems so petty. Why on earth would this matter in the end? I use it extensively for backups and restores. It is helpful to back up your phone from time-to-time....

  • This is how I have TWRP when I have MIUIeu, but it only indicates the incompetence of the Niantic programmers. Earlier after Prime left, there was a problem with Xiaomi phones. Now TWRP. Maybe it's time for Niantic to work on code quality instead of adding new avatars?

    @NianticCasey What is the current status of your bug fix? Because my reports to the helpdesk and others remain unanswered. (By the way, someone is working in the helpdesk at all? Is it just the wind flying between the windows there? ;) )

  • FalenoneFalenone ✭✭✭
    edited February 2020

    It's absolutely horrible to see nia locking down an open platform that is Android. There are legitimate use cases for root, such as flashing a new firmware on your older device to get more life out of it, ad blocking, backups and such. Why not instead have an actual anti cheat?

  • NineBerryNineBerry ✭✭✭✭✭

    How would an "actual anti cheat" be implemented while allowing phones that have root? 🙄

  • FalenoneFalenone ✭✭✭
    edited February 2020

    Server side? Why not detect if something is poking ingress app itself. I know a few players who rely on custom firmware because their phones are older and the OEM firmware is too old, 4.4 KitKat that is. not everyone can buy new phones all the time and you trying to force me to throw away my functioning device is a bit not nice

  • NineBerryNineBerry ✭✭✭✭✭

    You can't check the validity of a reported location server-side. Agents are very outspoken that they want Niantic to do something against spoofers. Some even say this is the one pressing issue that is making agents quit the game. So, Nia has to do something. Not allowing root is one of the necessary steps to do that.

  • RostwoldRostwold ✭✭✭✭✭

    A better solution for security is to assume all clients are compromised, and do sanity checking sever side, and you can sanity check reported locations easily.

    There are some really obvious moves Niantic could make that would be far better for deterring spoofers, such as requiring users to submit a photo of a portal if their movements speed is unlikely and accessing the portal would be strategically important (both calculable quite easily), then using wayfarer to validate the photos.

  • jontebulajontebula ✭✭✭✭✭
    edited February 2020

    I hope we can send in feedback about portals dont follow criteria to next update 2.40

    Lots of new portals dont follow criteria and agents and Niantic cant do nothing now to get portals dont follow criteria remove.


  • My one approved submission met the criteria I think.

  • What exactly do you mean by agents can do nothing ? Have you tried the report invalid portal option ? In app ?

  • jontebulajontebula ✭✭✭✭✭

    Nothing in Prime about portals dont meet criteria. We need it soon in Prime to get lots of portals dont meet criteria remove. We cant send in feeback about portals dont meet criteria.

  • All of these are obvious reasons of why the referenced portal does not meet portal criteria and must be removed . Maybe some reasons can be added or better an additional text box called so you can add "free" text. That might help indeed But obviously you can already act at the moment if you feel that you must report an invalid portal.

  • When more players are demanding spoofers be stopped than root access returned, you're in the minority.

    As for proof pics, that's not only a privacy nightmare, but also nothing remotely like a solution. Proof pics work in a community who know the people and place, not sent to random strangers for review.

  • @NianticCasey It's been 24 hours and people have lost sojourner. That was the plan? I understand that Ingress is a non-profit game. You opened up the OPR community to other games, and now you're doing your best to lose players to the end. You'll probably throw in a new avatar with the Easter Bunny as an apology, because you'll probably fix that bug around Easter :D

    There is the same mistake in Wizards unite. Helpdesk and support does not exist. Ticket number from WU: "5707070" See when I created it. 0 answers...

  • jontebulajontebula ✭✭✭✭✭

    I think not a bug. I think only Niantic block root on Android and jailbreak on Iphone. Works on my Sansung Gakaxy S10+ without root.

  • RostwoldRostwold ✭✭✭✭✭

    You're assuming blocking root access is an effective deterrent to spoofing, but as you point out, there are "more players are demanding spoofers be stopped than root access returned". I think that statement clearly demonstrates that blocking root access isn't working.

    From a computer science point of view, the right approach is not to trust any clients and move as much as possible to server side.

  • edited February 2020

    I am using Google Pixel XL Android 10. I have gotten the new update which give me the "not supported on this device" error. I had my phone rooted back before prime, I unrooted, uninstalled all apps that had anything to do with root, that worked until this update. Today after getting the error, I relocked my bootloader, factory reset phone. I still get the "not supported" error. Can we hurry up and get this fixed so I can play again.

  • sigh looks like niantic doesn’t like android anymore for some reason.

Sign In or Register to comment.