Prime 2.29.2 linking behaviour

One of the major selling points of Prime (for me) was the ability to skip linking animations on iOS.

However, the latest update broke this functionality to some extent.

If you skip the animation too soon after linking, it will not allow the next link (and even removes the possibility for this link in the overview).

I have been able to consistently reproduce this effect, and the only way to effectively skip the animation seems to be to wait until you actually see the link animation.

This requires atleast 1 second of waiting time after a link extra. This might not seem like much, but if you do max fielding it gets really annoying.



  • KhatreKhatre ✭✭✭✭✭

    Exactly, since 2.29 I get an error after first link link looks done but by going back to portal and link I can now do the link.

    I've messed up a lot of layers with that bug 😅

  • montitchamontitcha ✭✭✭
    edited August 2019


     I have this problem with the last update. 😭

    Is not possible to skip animation when i link or the 2nd link don't created.

    have to wait for the beginning of the animation before moving on but if you are not in the same city, you do not see when it is.

    it's not super convenient while the premium link function is so great 😍

    I have a Samsung Galaxy note9 SM-N960F, android 9.

  • Certainly feeling this one also.. I was seeing that it apparently did link stuff (shows the animation), and once done it doesn't show the link possibility any more, but when I leave the linking screen and check it has not linked at all.. and shows up as a possible link when you go back into the linking function.

  • Please think to check the insightful and like of the first for say it's important for us.

  • I also experience the same issue.

    Ingress Prime 2.29.2 on ios 12.4/Iphone xs

  • Took me some time to notice, but you can only press either "like" or "insightful". If you press "like" your vote for "insightful" is removed :P

  • Been experiencing the same bug after updating to 2.29.2. As has already been noted, I have had moderate success waiting for the animation to start and then cancelling it by swiping to the next key.

    iOS 12.4, iPhone 5s

    hopefully it gets fixed soon. The fast linking was amazing (it still is, but rather less so now...)

  • KhatreKhatre ✭✭✭✭✭

    Another example, 1st layer bugged.

    It seems that it works if you link fast enough to

    Ingress 2.29 - bugged link v2

    @NianticScot @RedSoloCup please address this to the dev team 😅

    The best part of prime is bugged 🙈

  • KhatreKhatre ✭✭✭✭✭

    Still no news for this.

    One major big to be fixed with the hourly crash/freeze

  • Nightshade13Nightshade13 ✭✭
    edited August 2019

    I had a similar issue last weekend.

    No keys to a specific portal would link, from any other portal (I only tried 3). I was going to make 3 layers over a major city but couldn't. I even drove 100km to break new blocks that appeared after the first field (my Son put up)!

    The issue I had was:

    The first field was put up by my Son, I dropped him a key to do it and it worked fine so it isn't my keys that are broken;

    Neither client would link to the target portal so it isn't a client issue (Redacted or Prime);

    I could link to other portals;

    I dropped all the keys I had and picked them up again when it wouldn't work and they still wouldn't link;

    I Ada'd the portal and re-linked and it wouldn't work;

    Just for the record, the link was 569km long and the portal had 900km range and no blocks.

    Unfortunately my Son was then not available to throw the other fields when there were no blocks.

    My educated guess is that this is a server side issue related to my account and has nothing at all to do with the client. Especially since Redacted hasn't been touched since November 2018 and I have been able to link to this portal before.

    Redacted Ver 1.134.5

    Prime Ver 2.29.2-ecc17158

  • @Nightshade13

    it's not the same problem. sometimes it takes several attempts for prime to agree to connect to a portal if it is a bit far. the best thing to do to force it and to have only the 2/3 keys of the field and to turn the carousel to the right.

    Prime always ended up giving me access to the portal, even if he made me a few frights.

    Perhaps you have a little link in the road to your portal.

  • There were no blocks. I tried from portals 30km apart and scoured the path. I even asked others to scour the path. It was completely clear. As I said, my Son made the initial field, I was just adding over the top the following day. When I replied to NIA support that if they checked the time stamp they'd see there were no blocks they responded that it would be fixed in a client update (implying they had validated that). However it's clearly not a client update. It's an account and specific key update in my case. I even dropped all the keys to try to reset them in case that was the problem? Since that's what I did when my son made the first layer, I dropped him a key.

  • Also:

    "3) If you say Prime sucks or doesn't work and you aren't using the latest version of Prime, download the latest and see if the issues exist. If they do, please let us know. But most of the complaints I'm still seeing are no longer issues. Even the long linking issue."

    lol. Really? Even the issue I had just last weekend with the fixed new client?

  • KhatreKhatre ✭✭✭✭✭
    edited August 2019

    Which ? The one with long link or the failing link during animation of this thread?

  • Same thing happened to me while I was finishing my 'fan' mutlilayers around my HP.

    Didn't notice the red linking error and kept on linking. Screwed up 3 multilayers because of that.

    Really annoying as I hate derpinking.

  • I was simply discussing general linking behaviour. I was using 2.92 at the time.

  • If you have a other problem, see if somebody have to open a topic or open a other topic. It's not the same problem.

    It's so complex to have to many things in only one topic. And it's better with more information of this. Sceen, version of prime...

  • This bug is still present in 2.30.2


  • thesolothesolo ✭✭✭✭✭

    Absolutely still present in 2.30.2, completely messed me up last night.

  • This bug has cost me 100k+ MU and a lot of time. Wasted time as a result of driving all around to create properly layered fields only to end up with unoptimal layering as well as extra time that I must spend on each and every link to back out of the link menu after each link and then wait up to 20-30 seconds for each link to make sure it actually linked.

    Can confirm it's still present on 2.30.2.

  • KhatreKhatre ✭✭✭✭✭

    @NianticBrian @RedSoloCup coule you ask if the failing link bug when animation pop introduced on 2.29 is addressed.

    The best part of prime - fast fielding - is broken 😥

  • starwortstarwort ✭✭✭✭✭

    I have a really old phone (Samsung S5) and made a layered field last night. Even without cancelling the link animation, the wait was 5-10 seconds per link. If it's taking any more than that, you have data signal issues. But then, Ingress 1.x was always a little unreliable in areas of low signal. Sometimes it would fail to make the link and the key would also disappear until a force-sync. But last night, using Prime, every link I asked for was made on schedule, and the indication that the link had happened was fairly obvious (chiefly because of the gained AP).

  • iFrankmansiFrankmans ✭✭✭✭

    Thanks for putting it on the list of bugs to investigate, hopefully it leads to a working fix soon, since it really keeps me from max fielding.

  • @Hydraulinski the link bug when you skip. All here

  • KhatreKhatre ✭✭✭✭✭

    Oh thanks that bug is messing with my clean multi layers.

  • Hi @NianticAkshay, bug is still in 2.32.2

    I would like to note that the version before you implemented the Dynamic Lighting was the one with the working link functionality. Can't remember if it was 2.27

Sign In or Register to comment.