Drone not moving properly / displayed drone location "resets" to earlier portal

YacatectYacatect ✭✭
edited January 2022 in Report a Bug

Starting since around 1-2 days ago I've noticed some odd drone behaviour.

  1. After moving a drone, attempting to hack will give an error message saying the portal is out of range. Exiting and reentering the drone menu will show that it is still at the previous portal, and needs to be moved again.
  2. Entering the drone menu will show that it is on the wrong portal, usually at the location before the most recent move. Attempting to move it to a new portal that's within range of both the displayed location and "correct" location will display the moving animation but attempting to hack will produce the same out of range error. Exiting and reentering the drone menu after this failure will show it at the proper location.

This started occurring after I got a scanner communication error from the drone menu after attempting to move it, and it also occurs when I tried reinstalling the game on a different phone, so this does not appear to be due to the device.

Device model: Xiaomi Poco NFC X3

Android version: 11 RKQ1.200826.002

Ingress version: 2.84.1

Connection: 4G/5G/Wi-fi

Post edited by NianticThia on
7 votes

Resolved · Last Updated



  • Amendment to #2 above: I don't think it's actually "resetting" to its earlier position, it seems like the game thinks the drone is in two places at once and each position can be moved separately, but only one position can be hacked.

    eg. It seems like if I move the drone from Portal A to Portal B then get an error while hacking, reopening the drone menu shows me as back at Portal A and if I move it to Portal C instead, the next error causes the drone position to be at B due to the earlier phantom move. Going to test this by trying to move in opposite directions every time I get the error and see if I really do end up in two places at once.

  • Update to the above: The game really does appear to think the drone is in two completely different locations at once, and intermittently decides to switch between which position can be controlled. I recorded a video of it occurring but it's too large to upload, so screenshots from it are below.

    Initial position after opening drone menu, this drone was able to hack this portal after the last move:

    Attempting to move and hack a different portal:

    The move succeeds but hacking produces an error message:

    Closing and reopening drone menu:

    Game has switched to the drone's alternate position and move timer is at zero again:

    Moved alternate position to a different portal:

    Alternate position can be hacked:

    For reference, this is how far apart the two drone positions currently are:

    It seems that:

    1. The drone is in two places at once and each location can be moved independently
    2. Only one position can be controlled and used for hacking at a time
    3. After a move, the game can randomly changes its mind about which location is correct, which prevents the now "incorrect" location from being hacked but will allow immediate movement and hacking at the alternate location

    I haven't tested if both drones show up on the drone layer and/or can be returned by attacks.

  • This exact issue started for me just yesterday. Everything you described. Had not experienced that before and came here to see if anyone else did. Mine had been working just fine until yesterday. I tried reinstalling Ingress, but didn't help.


    Device model: iPhone 6

    iOS version: 14.8.1

    Ingress version: 2.84.1-8d91d1d0

    Connection: 4G/Wi-fi

  • Apparently there was another player known to have 2 drones and reported it multiple times but kept getting told it wasn't a bug so they just gave up and enjoyed the double hack chances. I made this thread as a new report because I didn't know it was a double drone bug and assumed it was some kind of movement/position bug but after some testing, it seems to be a double drone bug since you can double your hacks when the drone "switches".

  • The number of times I have had a scanner communication error - and the most odd thing that has happened is that my drone appears to have returned to me when it has not actually. And a restart of the app fixes that glitch. I'd love to be able to experiment with this scenario!

  • Interesting. However, unfortunately, my double drone doesn't double hack. After trying this more, the first drone that appears for me never successfully hacks (neither director or glyph). It always shows the error "Portal not in range".

    Then I close that screen and start the drone again. It goes to the second one and I am able to hack either way with that one.

    If I was able to double hack, I probably wouldn't complain. lol

    It's just more annoying the hassle of going back and forth as well as both drones skipping back a few portals every now and then.

  • That's interesting. In my case, I noticed that although sometimes it'll give the "Portal not in range" message after a move and attempted hack and switch to the other drone when the drone menu is reopened, the next time it switches back it's possible to hack the current position (that failed the last time) before moving.

  • I have the same problem, but I've been rotating the same portals for months now so it always ends up at one of them, never at a portal far away from that group.

    In general I get the "Portal not in range" message very often and that's purely annoying. But occacionally I recieve an extra hack since I always try to hack the current portal even if I know that it is supposed to be burned out, then move and then hack again .

  • DizzyBumDizzyBum ✭✭
    edited December 2021

    This same behavior started happening to me as of a week ago. Originally I thought the drone just randomly came back to me, but now after experimenting with it, I seem to have the same behavior as described above where the game thinks I have two drones and randomly shows me one or the other.

    Clearing cache/data and reinstalling the app did not help.

    Device model: Samsung Galaxy S9

    Android version: 10

    Ingress version: 2.86.1

    Connection: 4G/Wi-fi

    Post edited by DizzyBum on
  • I would not describe mine as double drone, more like one drone with severe amnesia :P

  • LluminaireLluminaire ✭✭
    edited December 2021

    I have this problem as well and it started around the same time in November.

    I can see two drones in the scanner and have confirmed with other agents that they can also see both of the these drones from their scanners.

    When my drone got returned recently I got two drone return notifications (see shot attached).

    I can't hack until I've moved both drones, have deleted and reinstalled app and no change.

    I've reported to support who insist it is just a visual glitch on my scanner and it should resolve on deleting and reinstalling, which it doesn't.

    It would seem to me that this is a server side problem given that even my notifications think I have two drones @NianticThia is this something you could raise on your side please?


  • @Yacatect @Shrikesong @DizzyBum @QuiksilverSE @Lluminaire I have checked under the hoods of your Drones; can you see if they are flying better now?

  • Hi @NianticThia just gave it a test run and it's looking pretty good 👍🏻 moved and hacked first time. Thank you 😊

  • Yes, thanks. Mine seems to be working normally now too.

  • starwortstarwort ✭✭✭✭✭

    @NianticThia I appear to have this as well and am curious to know how it's even possible for a player to have two drones (one of which doesn't work).

  • Hi @starwort - see if your drone is behaving better now.

    At this point, I can only speculate at a super high level what is going on and have no data or knowledge to know if it's even possible I[m not going to share that lol - for now, since I can at least fix it for folks, I'm collecting info for the team to use to try to pinpoint.

  • starwortstarwort ✭✭✭✭✭

    Yes it has been working today. :-)

  • I've had zero issues the last couple of days, thanks a lot! :D

  • I've had the same problem as originally described since last week. Any chance you can check on mine, too, @NianticThia? Thank you!

  • Probably since yesterday, I seem to be having the same problem. Would you give me some advice on what to do,  @NianticThia? Thank you.

  • I cant suddenly acsess to dronenet. When i hit the dronenet button i just get back to the where i am. And i says communication error in scanner

  • NianticThia I have been having the same issues since November. Could you please check and see if you can get my drone working? Thanks!

  • I have been having the same issues as above with my drone. How do I get NianticThia or someone to check into this? Drone in one location (city), recall and deploy in new city. May move once or several time then all of a sudden it's in the first city. It will stay in one location all day or move cities every hack. I have moved the drone, hacked and receive Portal not In Range message, restart game and it's in a different place.

  • I am also having this issue since Jan 12.

  • An update. In an attempt to address this issue I've tried recalling both drones, a forced return (capturing a neutral portal one drone was on), and deploying them on portals a few kilometers apart.

    Looking at corresponding portal keys with the Dronenet layer on and my drone deployed, I can see two drones which appear to be mine. They seem to travel together, even after various attempts like the above.

    Unfortunately, nothing I've done seems to correct the issue. I'm back to having two drones whenever I engage Dronenet.

    Still hoping for a reply from @NianticThia. Pinging @NianticBrian here, too. Thanks in advance for any assistance you may be able to offer.

  • DizzyBumDizzyBum ✭✭
    edited January 2022

    Update to my situation - The issue seemed to resolve itself after a week or so, but I can still see my "extra" drone sitting on the portal where I last accessed it.

  • @SKSM5966 @StayDream @Sis1 @DementedTulip Please see if your drones are behaving better.

    @MajorDolje I need to look further into yours.

    @DizzyBum Everything looks OK from what I can see - it's possible the other drone you see is someone else's and not yours but as long as it looks good on my side and it's working properly for you, then I'm happy. :)

  • @MajorDolje - are you still experiencing this issue? From what it's looking like on my side, it may be working. Please advise!

  • @NianticThia mine is partially fixed. I only control one drone now, but the other one is still sitting on a portal, orphaned

  • No it is not. Last evening it was returned to a portal had been to the day before. Still getting "Portal not in range" off and on when trying to hack.

This discussion has been closed.