capsule names lost

Names are sometimes lost on capsules that have been sitting on the ground.

I put names on capsules so I can see whats on the ground without picking it up. We need to pick up and drop all capsules every 12 hours, and about every 2 days I find at least 1 capsule that lost its name.

Is this a known issue?

Tagged:
5
5 votes

Investigating · Last Updated

Comments

  • It depends on the cycle time and your app restarting, I believe. The name is only maintained in phone memory once you drop it, so if your app restarts, there's no knowledge of it.

  • DestroyerTJDestroyerTJ ✭✭✭✭✭

    Yes, this is an old mistake, it is good that you remembered it. It also occurs if I give the capsule a name, discard it, it gets lost, another agent lifts the capsule and it already has a standard name in numbers, letters.

  • phthoruthphthoruth ✭✭✭


    I dont think thats it. I restart my ingress app about 10 times a day, due to the various bugs. When I go back to the capsules, most have their names... its just 1 or 2 that lost theirs. The rest are fine.

    Just to be sure I tried it.

    Test 1: restart

    I dropped a named capsule. Killed ingress. Rebooted the phone. Started ingress. Picked up the capsule. It still had its name.


    But if the name is only stored on device, perhaps its a cache item that can get flushed.

    Test 2: uninstall

    Dropped the capsule. Uninstalled Ingress. Restart phone. Install ingress. Pick up capsule. Name is still there.

  • phthoruthphthoruth ✭✭✭

    So you're saying if I drop a capsule with a name, and someone else picks it up and drops it, then I pick it up, the name is lost for me?

  • phthoruthphthoruth ✭✭✭

    I asked 2 locals about this.

    one said they've seen names lost on their capsules as well, when they were on the ground.

    the other said if they gave someone a capsule with a name on it, when it was given back, it still had the name.


    So its seeming like a bug, and known issue.

  • NineBerryNineBerry ✭✭✭✭✭

    When picking up a capsule it sometimes takes the game a few moments before loading the name of the capsule from the server and you will see it without one (only numbers).

    So: If you encounter a capsule that "lost its name", have you tried just waiting, then reboot the scanner to see if the name comes back after that?

  • EvilSuperHerosEvilSuperHeros ✭✭✭✭✭

    I've had that issue. Dropped named capsules of resonators when micro fielding and managed to pick them up later in the day and the renamed capsule had reverted back to it's original name (after being on the ground for almost 12 hours).

  • I first reported this issue more than a year ago, and repeated the report several times since then.

    Looks like they just don't care.

  • I'm not sure if its a factor, but I routinely pick up my capsules after 12 hours. e.g. 13 hours. Technically the sweepers can sweep them away any time after 12 hours, but most of the time you get a bit of lea way.

    I drop a lot of capsules, and only see this every 2-4 days. I tend to name things with duplicate names, such as 'cubes'.

    That way I can click on the pile of capsules and see what I'm picking up.

  • Just adding some observations:

    If I name a capsule, then check my account on another phone, the name is still there, indicating it is stored on the server.

    I have not seen a capsule I've not dropped lose its name. If it happens, it is extremely rare.

    I've passed capsules to another agent, and when they returned me the (empty) capsule within minutes, the name is intact. I have not tested what happens if they hold it for a day, but I expect the name to disappear.

    I suspect this might be due to some garbage collection / cleanup being done on the server side. Obviously just a guess since I've no idea how the backend is implemented. If it is indeed due to garbage collection, it would be good if the interval is tweaked so that a capsule on the ground for less than 12 hours will not lose its name.

  • phthoruthphthoruth ✭✭✭

    I saw a lost capsule name this week. Just to confirm its still an ongoing issue with the current scanner/server.

Sign In or Register to comment.