Ingress 2.49.1 Release Notes

What’s new:

  • Dronenet improvements: Added a visible cooldown timer and updated the notification dot so it's easier to see when Drone Mark I is ready to move.
  • On Android, after Agents level up or earn an achievement medal, we added a request prompt to rate Ingress on Play Store. Play Store ratings can help us encourage new recruits to download Ingress, so if you’d like to leave us a review or share feedback, our team would greatly appreciate it.

Bug fixes:

  • Fixed a hang on startup affecting specific devices on Android 5 and 6 (including LG X power; Samsung Galaxy Core Prime; Asus ZenFone Go).
  • The tap target of the Glyph hack Redo button is slightly larger to make it easier to select.
  • After completing a mission objective, you can now see your next mission objective more quickly rather than wait for the checkmark to clear.
  • Fixed Drone Mark I visible during Capsule management.
  • Fixed Drone Mark I appearing to count towards inventory capacity.
  • Fixed Portal brackets disappearing in Drone Footage view.


  • lzLuislzLuis ✭✭

    ༼ つ ◕_◕ ༽つ Give 60fps mode

  • @InvestigateXM a new Agent should only see this prompt the first time they level up or earn an achievement. The next time the prompt is shown wouldn't reset or display until significant time later, again after leveling up or earning a new achievement.

  • InvestigateXMInvestigateXM ✭✭✭✭✭

    Good to know! Maybe a small suggestion, wait to show new agents the prompt to review until after the choose their faction a second and final time at L3 (or 4?). By that point, they should have gotten a grasp of how Ingress works and if they like it. If I remember correctly, you'll get to L2 within the tutorial, and at that point, new agents can't really give an honest review.

  • GrogyanGrogyan ✭✭✭✭✭

    DroneNet should really have a push notification when it is ready to use again.

    • This also helps with sojourner, as it will show the time the push notification was pushed.

    The outstanding issue of the GPS jumping around is still a major issue.

    • This is not the same as GPS drift, and is replicable on a lot of different devices, on different cellular networks, on multiple different versions of Android

    There is a rumour about dropping support for 32bit mobiles, can you please elaborate if this is indeed true for Ingress

  • BurliBurli ✭✭✭

    So maybe it's time for new badges, so that we can rate the App:)

  • Do the update also feature a new section for Drone activities? The current placement makes the stat page too clumsy.

  • Double swipe is no better, even disgusting.....


  • ItsutsumeItsutsume ✭✭✭


    1. Sorting by name still doesn't work. Only works once after the game is started and you go to keys. Exit keys, or move around, or hack something, and sorting by name will not work anymore until the game is restarted.

    2. Sorting by distance also doesn't work properly. It seems that the key it uses for reference needs to be at the top and off screen. (I think we need a carousel so that the game knows which portal is selected, which should fix both issues. Why did they remove the carousel just for keys?)

    3. "XM reserves critical, XM drained, scanner offline, resonators recharged, XM acquired, XM reserves online, scanner online, good work" when charging.

    4. When charging portals, sometimes they are not shown on the screen.

    5. Magnetic arrow on devices without compass doesn't point North. Instead, the avatar is rotated when map is rotated. Need to leave avatar pointing up and the arrow should rotate with map, like it was in Redacted.

    6. When viewing remote portals, sometimes get notifications that links/fields were created or destroyed or get portal attack sounds and animations even if it was hours ago and no one is currently in that area.

    7. When recharging portals, sometimes when there's less than 1000 XM left to full charge, regular charge will take way less than 1000 XM, maybe about 500-600 XM, even though the portal is within a few miles and regular charges before that were taking about 1000 XM as they should.

    8. When picking up items, Acquire button is not grayed out if the item is out of range like it was Redacted. It's quite annoying to press it only to find out you're out of range and then have to find the item you want to pick up again when it's next to some portals.

    9. While viewing agents' stats, can't scroll if I press on mission badges. I have to press on something else in order to scroll.

    10. When taking items out of or putting items into capsules (regular or quantum) it shows incorrect item count. For example, if I have 2000 items and want to take 2 items out of a capsule, it would show 2002/2000. If I want to put 2 items into a capsule, it would show 1998/2000. Once transfer is completed, it would show 2000/2000 again.

    11. When pressing on a portal that's close to another portal or portals, the portal selection menu appears for a moment and then disappears. Pressing on that portal the second time shows the selection menu, and this time it stays.


    1. No portal hopping like in Redacted. We could look at a portal from alerts or actions, then press on a portal nearby, and if we had a key to it, we could "hop" to it, and continue hopping as long as we had keys to nearby portals.

    2. Is it possible to get rid of "It has been XX hours since your last login. I was getting worried about you"? Sounds like overly attached girlfriend. No, we don't need to change that to Jarvis voice, it will be even creepier. "It has been XX hours since you last login" by itself is OK, but I never understood the point of it.

    3. Can’t see own actions in COMMs. We were able to see our actions in COMMs in Redacted.

    4. According to Intel Map, neutral portals are level 0. In Prime, neutral portals are shown as level 1 when looking at keys. Is it possible to make them be shown as level 0?


    1. When scrolling thru keys, they jump around and show some keys twice.

    2. Need some indicator, like red circle in Redacted, to know where North is, especially considering that portal view randomly rotates either clockwise or counterclockwise.

    3. Considering that sometimes it takes several seconds to load portal data when looking at keys, is it possible to NOT show portal level at all until data gets loaded? Currently it would show level 1, then whatever level it actually is after data gets loaded.

    4. Can't scroll in COMMs as after a few seconds it takes you back to the bottom.

  • @NianticBrian any possibility Recruiter badge can come back if you're now asking people to rate the app upon leveling up?

  • AtunatunakAtunatunak ✭✭✭✭
    edited June 2020


    The bug of Battery Saver Mode not working is still present in this version.

  • still no news about changing the double swipe to optional on IOS.

    It's increasingly annoying, please ☹️☹️

  • jontebulajontebula ✭✭✭✭✭

    Still no solved the bug with all padlocks. I cant read nothing about solved the bug with all padlocks. 😭 @NianticBrian

  • emmesevenemmeseven ✭✭
    edited June 2020

    BUG: after you've deployed, opening another portal's deploy button, ADA says "resonator deployed" before any action taken.

    BUG; when using dronenet, after moving Mark I, hack sometimes fails complaining about XM. Restarting the app makes the hack possible again.

  • jontebulajontebula ✭✭✭✭✭

    Yes! Only tutorial start and not help. Only i can do wait for Niantic to relese the update for resolve padlocks bug. I hope Niantic soon work hard to resolve the bug.

  • M4rvz2M4rvz2 ✭✭

    Sorry. What I meant was you need to end the tutorial. That should remove all the locks.

    You will know that it worked if the end tutorial button disappears.

  • jontebulajontebula ✭✭✭✭✭

    If i now click on end training the tutorial start and i must select faction again. I only must restart and not select faction and start from L1 again and lost everything i do. Ingress never start traing only start training if i click on end traing. Not help for me. 100% bug and wait for new update when Niantic resolve the padlocks bug.

  • M4rvz2M4rvz2 ✭✭

    I'm giving you the solution. End the training now and those locks will disappear. You won't lose anything and you won't go back to level 1. I tried this just now. Started and ended the tutorial. I didn't lose anything and I didn't go back to level 1.

  • jontebulajontebula ✭✭✭✭✭

    Not end only start tutorial when i click on end training and new to L1 if i continue.

  • @jontebula from what i've been reading up on what @M4rvz2 said is correct i also remember doing the training over and over on my account and collecting loads of L1 XMP Goodies from ADA before i grasped how the game actually worked and then my feet just wouldnt stop moving...i got addicted to the actual game and although i havent been out since december 2019 (with the game,im not a hermit) due to my own game bugs that have still yet to be fixed i can confirm from my point of view that you can "end training" at any point and it will go back to your main account...however i did it from within the settings menu and then i clicked end half way down the menu before that button was there on the main screen.

    I used training mode to refresh myself on hacking and linking and will probably use it again IF my BUG ever gets fixed from a kind DEVELOPER. Yes im looking across at you @NianticBrian :D

    So dont worry you wont lose any built up work you've done...if it happens then report it back to this thread.

  • DSktrDSktr ✭✭✭✭

    In this release - drone can't be used to hack a portal after movenent,it tells smth like "xm object doesnt exist",that can be fixed by exit-reenter " drone network".

  • jontebulajontebula ✭✭✭✭✭

    Same bug with padlocks in 2.49.1 😪. Please resolve the bug soon @NianticBrian

  • M4rvz2M4rvz2 ✭✭

    Can you at least try ending the tutorial and see what happens?

  • jontebulajontebula ✭✭✭✭✭

    Cant end tutorial only start tutorial if i end training. Only i can do wait for Niantic relese update resolve the bug. I hope Niantic work hard to relesove the bug soon.

  • HydracyanHydracyan ✭✭✭✭✭
    edited June 2020

    I'm getting this message sometimes now. I fix by leaving the drone view and returning.

    Post edited by Hydracyan on
  • mistake.

Sign In or Register to comment.