BUG: Repeatable crash in keylocker management

Crash is 100% reproducible for multiple agents.


When loading keys into a keylocker, select the key, let's say five from the right, so there are 4 keys right of it (assuming 1 of each key), then your selected key. Then, tap that key until it shows 1 selected. Then press the "select all to the right" button.

This will now show SIX keys selected, even though it only has 5, and then when you press load, it hangs the game.



  • Bulk loading is broken for me if I have any keys selected when I hit the "select all to the right" button. The game gets stuck on the transferring screen at that point, though I can back out with the android back button to the previous screen so it is not a crash for me. As the OP said, the count of selected keys is wrong as well. Bulk loading when nothing is selected still works.

    Device: Moto Z Play

    OS: Android 8.0.0

    App Version: 2.35.2

  • 3 keys selected in total, but only 2 in the inventory 🤔

  • I can reproduce this with as few as 2 keys. It can be qty:two of the same key, qty:one of two different keys. I can reproduce with both key capsules and quantum capsules. At about a20% failure rate. Have not tried regular capsules yet. Loading 100 keys is far higher rate, nearly 100%

    No problem unloading keys

  • So I think there are 2 bugs here.

    1- repro

    Go to capsule

    Go to last key

    Tap on key so you load 1 into capsule

    Tap on load all key

    See that"selected" now says 1 more than the actual number of keys you have (screenshot above by the coding frog)

    Tap load and it hangs forever

    I can repro this with any capsule type

    Workaround is to not tap on the key before using load all

    2- my post above I never used load all, yet I could still cause hangs loading 2 keys, though I have not seen it recently.

  • Capsule and key management results in crashes of the game so often, I have a player who has stopped playing because of that.

    Crashes on recharge are about to make me quit

    Lack of alerts, crashes while playing and so on.

  • I have same issue. Now can't hack or breed anything because I'm over inventory limit...

  • tofucioustofucious ✭✭
    edited May 10

    Been searching on this as the last couple of days I've experienced this. It's been either 1 or 2 lockers that I can't fill, depending on when I've tried. Yesterday I could fill 4, today I could fill 5 until this evening - back to 4. It's not fussy which lockers, just that I can only fill 4 or 5 at a time. Cleared data and cache, uninstalled and reinstalled, all the usual stuff.

    Using a Pixel 4 - Android 10

    App version - 2.46.1

Sign In or Register to comment.