[Bug Report] "Missing Portal Key" Error Incorrectly Shown When Recharging Portal

TinderbiscuitTinderbiscuit ✭✭✭
edited October 2019 in App Feedback (Archive)

Phone Model: iPhone XR

Software Version: 12.4.1

Model Number: MRY42B/A

Client Version: Ingress Prime 2.32.2-2101f14c

Service Provider: O2 (UK)

Bug Description: Despite holding keys for the portal, standing within 40 metres of the portal and having sufficient XM, the user was unable to recharge the portal.

User Expectation: User should be able to recharge a portal if they have a key or are within range of the portal and have sufficient XM.

Video: https://www.youtube.com/watch?v=k0srdsm42O8

Repro Rate: <10%

Repro steps:

1) Open Ingress.

2) Walk to a portal with 1 damaged resonator

3) Deploy 7 more resonators.

4) Glyph hack the portal for keys with the "more" symbol.

5) Ensure that the user is within range of the portal, at least one key has been obtained and that the user has sufficient XM to recharge.

6) Attempt to recharge the portal with the "boost recharge all" button. Observe the error message "Missing Portal Key".


Unsure as to whether user previously had a key to the portal before glyph hacking.



  • I get that but I think I’ve figured out why it happens to me at least. I only get it when I glyph hack the portal I’m on, using more key hack, I **** all keys apart from one, and then I recharge the portal.

    Its like the message to **** that portal’s keys goes off to the server and the backend has to do lots of stuff with your key management so isn’t able to look at your key inventory.

    Need to check that reproduction and amend your post if so, as I think that’s the... key to the bug.

  • It happened to me once. I have 4 keys on hand, after I made a link to that portal, the portal couldn't be recharged and says "missing portal key". I have tried to refocus but the error persist. I went to another portal and made a link to it, recharged, again same error.

    Then momentary later it works again. I have no idea how I triggered it and how did I solved it.

  • So the key will have disappeared from your inventory once you linked to it. And the system somewhere was locked out of knowing if you had more keys. Must be something to do with some key management process.

    Best thing until fixed is charge portals before doing anything that effects the keys.

  • It happened to me too many times.

  • I concur. I've found similar. It seems to happen if I do a glyph hack and request keys. I recycle them and then see the error message.

    It's like the server keeps a list of each key in a list for this portal and recycles (deletes) the one that the app caches off for the portal.

    1) I enter the portal screen. It caches the key I have currently in my key list for the portal on this screen:

    KEY LIST: [A][ ][ ][ ]

    2) I glyph hack the portal for more keys. After hack:

    KEY LIST: [A][B][C][D]

    3) I recycle 3 of the keys. Keys are FIFO. Recycling removes keys A, B, C.

    KEY LIST: [D][ ][ ][ ]

    App tries to use the original key associated with this portal (A) to recharge it but it no longer exists so it fails.

    That's my theory, anyway... Maybe that's not actually what's happening, but I'm a programmer and my gut says it's something along those lines.

  • Pixel 2, Android 10, Prime Version: 2.36.1-de068883

    This is mostly fixed, but not 100%. I'm guessing it happens to me about 5% of the time, so it takes 20-40 tries to repro it. However, I have a technique that makes it far easier to just sit there are reproduce:

    1. Hack a slightly discharged (~2 days ) portal a bajillion times to get like 50 keys.
    2. Drain your XM bar to 0 by charging some OTHER portal.
    3. Enter Inventory
    4. tap Portal Keys
    5. select portal
    6. tap recycle, recycle ONLY 2 keys to get 1000 xm
    7. tap x ONLY ONCE
    8. tap Boost Charge All

    95% of the time, you get a successful recharge and +10 AP. Go back to step 6 and lather/rinse/repeat until you:

    5% of the time, you get: "[Missing Portal Key]" error

    Note that I've turned my phone off (i.e. just tap the power button, so sleep, not actual power off) for an hour, picked it back up, and the scanner (client) is still stuck in this bad state, so waiting doesn't cause the client to refresh out of it.

    However, hacking a portal (not sure if it needs to be the same portal, or another) does seem to fix the problem, so you don't necessarily have to restart to fix the bad client state. This isn't an option if you're sitting at home (no portal) and bulk recharging all the keys in your inventory.

  • I think it is only necessary to recycle one of your keys and then try to recharge.

    Even if in range of the portal.

    I also think you lose the xm.

  • I've had this happen, it seems to be coinciding with using the key icon on portal view rather than going inventory> keys and then recycling.

    I'll try reproducing it when I'm out next.

  • Yep, recycling from the key icon on the portal page.

  • It has happened to me today. Latest game version on Android 9.

    I had 8 keys of the portal and as I was getting closer to it I recycled 5 of them, then attempted a boost charge, then received the error message. I got within range, still the same error. I glyph hacked, got 2 more keys, error persisted. App restart "fixed" it.

  • I also have had this problem when recycling some, but not all, of the keys I have out for a given portal.

  • It even happens when you are in range of the portal - so don't even need a key.

  • Still occurring, I saw it a week or two ago.

Sign In or Register to comment.