[Bug Report] Mission hacks/action not recorded (2.31.2)

AndyRozmanAndyRozman ✭✭
edited September 2019 in App Feedback

So I tried (again) doing mission on Prime (2.31.2) and it worked much better than on previous versions (no app freezes, except one full reset of my phone), but I noticed a weird occurrence. Sometimes I would hack or visit waypoint, but this visit was not recorder. Portal is still showing that I have to make it. Going forward to next portal doesn't work either, because not-recorded portal is still there...

Workaround was to restart Prime, and then I could see that portals were hacked and I could continue mission.

Tagged:

Comments

  • RostwoldRostwold ✭✭✭✭

    Can confirm this (2.31.2, iPhone X). It seems to just be a visual bug. If you restart it fixes itself, and if you ignore the indicators on screen and just continue the rest of the mission it will still be recorded as complete.

    I suspect this might be a re-syncing issue if a wifi to G3/G4 handover occurs around the time a mission action happens, but I'm all out of missions near wifi networks to test this with.

  • I actually couldn't finish my mission without restarting the app...

    If you just continue (and mission is sequential), you would see portal X1 not done, and when you hack X2 you would still see both as not done and X3 wouldn't be marked as possible portal at all, so you can't hack that at all.

    Its bug in software. Now if situation would fix itself, after you hack the next portal then it would be just a simple issue, but now you have to go and restart app...

  • RostwoldRostwold ✭✭✭✭

    Interesting - I was able to hack the last portal even though it was not indicated, and then the 'did you like this' screen popped up.

  • I could finish the mission without restarting the app, the following waypoints were marked as done, after the last action the mission was completed.

    See here, with screenshot: https://community.ingress.com/en/discussion/4131/erroneous-mission-prompts#latest

    It happened with every mission I tried to play (ca. 15-20) with good network all the time.

Sign In or Register to comment.