Top Ingress Prime Bugs - 1 Month to go

Today marks 1 month until Ingress Prime is the only client, and in my opinion there are several bugs that must be addressed before this happens.

I posted about some of the same concerns 1 month ago, here it is for reference: https://community.ingress.com/en/discussion/2817/ingress-prime-bugs-in-priority-order

For context, I play on an iPhone 8 Plus with the latest stable iOS (currently 12.4.1). I'm only looking at bugs and not feature parity. All bugs are present on Ingress Prime version 2.29.2-ecc17158.

Here they are in priority order:


1. Getting stuck on "Command Channel Open" while glyph hacking.

Despite the release notes for 2.27 claiming to have fixed this issue, it still occurs for me every day. It seemed like 2.29 might have reduced the frequency at which it occurs, but I'm often still getting stuck. It's (almost?) never on the first hack after restarting the client, but usually it takes several hacks before it starts getting stuck. Once it starts getting stuck it will almost always continue to get stuck on subsequent hacks, with the frequency of getting stuck and the duration of being stuck increasing as time goes on until the client is restarted.

Once stuck, the only way to get unstuck is to input commands or else just draw randomly every few seconds. Eventually (sometimes after 1+ minutes) the hack will proceed normally. If no further input is given after getting stuck, you will be stuck presumably until the end of time (have tested this out to several minutes).

Now for some anecdotes that should be taken with a grain of salt. When sitting in one place hacking the same few portals I don't seem to get stuck. When I don't input any commands I don't seem to get stuck as often. I often get stuck when I'm walking around interacting with many different portals in a row.

This bug alone has wasted many hours of my time over the past few months, and time is your most valuable and limited resource when playing Ingress. This bug is well deserving of the #1 spot.


2. Linking issues

When linking, the view of the destination portal is often incorrect or takes a long time to load in the links and fields around the portal you're linking to. This often makes it difficult to know if you're linking to the right portal if you aren't 100% sure.

2.29 additionally introduced two new bugs with linking:

  1. You can press the link button, the destination portal is removed from the carousel, but the link is not actually created. This has cost me probably around 100k mu in the past week due to messed up link order even though I hit the buttons in the correct order.
  2. If I'm eligible to link to two (or more) portals, linking to one of those portals often incorrectly removes a different, still-eligible portal from the carousel. This requires me to back out of the linking interface and re-enter it after every link to ensure I'm seeing all the correct destinations.

The two new linking bugs make linking on Prime very tedious and error-prone.


3. Unending speedlock when switching apps

I've found if you don't have Ingress Prime on the screen when you are traveling at highway speeds, and then you switch to Prime once you arrive at your destination, you can get speedlocked as if you just teleported from wherever you used to be to your present location. This can cause a very long period of time where you are not allowed to do any actions, even while sitting completely still.

When this occurs switching to Redacted allows actions, but soon that workaround will no longer be possible.


4. Interactions are no longer triggered when pressing UI elements, instead triggering when the press is released

I'm treating this change, introduced in 2.27, as a bug because it seems to be causing issues throughout the app. This has quickly become a source of frustration when using Prime since the new UI update. Since now where your finger is when you release is important when it didn't used to be, additional precision is required. Here's some examples of areas impacted by this bug:

  1. I'm constantly running into "portal out of range" messages now when attempting to hack a portal that I can just barely reach. It used to be that if you could press the hack button you were able to hack the portal. Now that's no longer the case. This is especially noticeable when swiping the hack button to glyph hack, hack-request-key, or hack-no-key.
  2. When long-pressing Fire to charge, moving your finger even very slightly cancels the action. This is especially a problem because the Fire button was changed from being a large button that was easy to press to being a tiny button that is hard to press reliably.
  3. Swiping the main button into a menu now can press buttons in that menu when you release your finger. Like when swiping into inventory, if your swipe ends on the manage button you're instantly mass-recycling without meaning to.


5. Medals / missions / keys displaying blank images until the app is reinstalled

As I type this my three most recent medals are showing up as blank, despite reinstalling just a few days ago. Medals are often blank when I get the popup letting me know I earned a new medal, which was pretty disappointing as I like to screenshot my gold+ medals earned. So my onyx Recharger, platinum Trekker/Translator, and gold Myriad Hack medals were all just blank hexagons. My profile loads properly after reinstalling but it often looks like this:

This is also a big problem with keys, as the images are a good way for me to quickly locate the correct key when I'm trying to find one in my inventory or in a key locker. But when some/all the images are blank it's pretty difficult.


6. UI buttons disappearing

Sometimes buttons disappear in the inventory menu. Notably the "Manage" button for key lockers and capsules will disappear, and the "Recycle" button within the mass-recycling mode for resonators/weapons/etc will disappear. I can get the "Recycle" button to reliably disappear by hacking a portal, then quickly going into inventory then mass-recycle mode around the same time that the box listing everything you got from hacking is displayed. To restore the button you must exit out of the inventory menu, tap to close the hack results box, then try again. But sometimes this bug occurs even without hack results on screen.

Comments

  • slalomzslalomz ✭✭✭

    That's true! Doesn't work with the +/- buttons though when trying to recycle, those sometimes disappear as well.

  • I get all of these but the worst is the first, getting stuck on “command channel open” while glyph hacking. It can take up to 5 tries to get any response to the more glyph.

    iPhone XR.

  • This is about the best list of most important problems I encounter every day. The bug list seems to think that these are fixed or don't exist.

    Odd thing is that these problems have been there since the public release and they are quite debilitating. I really can't imagine using this during an anomaly. You don't want to reload the ap when time is important.

  • Build 2.30.2-43590c45 (Updated today so it's the most recent version)

    Key capsules stopped allowing me to load or unload them. Had to restart the app to resolve it.


    Over the weekend the previous build wouldn't load in low signal areas. Redacted loaded and played just fine.

  • From some of my fellow agents on Android I hear it's constantly locking up (i.e. application freezes with restart needed) while in the keys section also (e.g. charging) - it might be related to phone/OS for all I know, as others seem to not have this problem (and it doesn't happen to me on iOS). With an anomaly coming up in October, this seems to be really, really, really bad....

  • #1 - I've mostly gotten rid of this by turning OFF the "Battery Saver Mode" in Prime. The instances I do still get are far shorter in duration, and probably down to actual network delays/packet loss.

    #6 - Despite the new 2.30.2 bug of the Manage buttons sometimes being dimmed right down, but actually still working, yes, this is still a thing in 2.30.2. I've not yet seen the Key/Item Recycle variant of this, but it's been less than a day on 2.30.2 and it always showed up less often for me.

  • I can confirm issues 1, 2, 3, 4, and 6 are all still present in 2.30.2.

    Although I haven't gotten any particularly bad occurrences of issue 1 yet.

    As far as 5, all my missing medals loaded after the update - remains to be seen if they go missing again.

  • Top bugs are - launch speed(too long),bad visibility,messed out and soundless alerts,high power/traffic consumption.

    All mentioned above are annoying,just like overlay bug when try to glyph an portal before ui will load,- but not critical(only stuck in glyph is a trouble but i haven't faced that at all).

  • UI Buttons disappearing is my most annoying bug atm. It comes too often and it can only be resolved by restarting the client.

    I've made a short video showing that state:

    https://youtu.be/5HD5_WVw1SA

  • thesolothesolo ✭✭✭✭✭

    Number 2 is 100% still present in the .30 release. It bit me hard last night. Very, very frustrating.

  • thesolothesolo ✭✭✭✭✭

    The other thing that happens when you long-press to fire, it keeps 1 finger rotation enabled. So if you move your finger even slightly horizontally, the screen starts to move sightly, giving off a jerky feeling that is very distracting.

  • That speedlock issue is awful, especially combined with the startup time of 60-90 seconds at a minimum, poor low-signal performance, and wonkiness of the key carousel in the linking screen. I really try to avoid opening REDACTED, but every time I try to field tight to checkpoint in my rural AO, these issues seriously interfere until I can open the old app. It's just not a fun experience anymore... I'm not one of the agents saying they're done with Ingress forever once REDACTED is shut down, but if I can't play the rural fielding game because it's become an exercise in frustration instead of my favorite outdoor competitive activity for the last nearly five years, it will be the end of an era for me and many other agents.

  • Totally agreed. Ran into the unending speedlock issue again yesterday. Was sitting there for several minutes unable to take any actions in Prime. Restarted Prime and still locked. Switched to Redacted and everything worked.

  • "3. Unending speedlock when switching apps

    I've found if you don't have Ingress Prime on the screen when you are traveling at highway speeds, and then you switch to Prime once you arrive at your destination, you can get speedlocked as if you just teleported from wherever you used to be to your present location. This can cause a very long period of time where you are not allowed to do any actions, even while sitting completely still.

    When this occurs switching to Redacted allows actions, but soon that workaround will no longer be possible."


    This is going to be my biggest problem with Prime, Right now visibility kills me when I visit a new city, and I want to find portals to interact with, but Speedlock makes the game almost unplayble living in a rural area. with portals 1-3km apart you have to shut the app completely off between portals just to be able to play. it is SLOW and consumes more data it seems,( though I haven't been able to actually test/see how much more )

  • I am getting #2, #3, #6 and the freeze every 20~30min issue. For me the freeze is most annoying.

    The freeze mostly happens on recharge or key list page here. My phone is OnePlus 5T with stock H2OS (Android 9), in case this helps.

Sign In or Register to comment.