Prime not loading

I still can't get Prime to load at various locations (including my home address, and my workplace) all I get is the location acquired and spinning globe.

I raised a ticket, got the reload game, clear cache advice, which I repeatedly did, and nothing further

Redacted loads quickly and easily wherever I have signal. Wizards Unite also loads, so this would appear to be purely a Prime problem.

Any help would be appreciated.


  • If the globe keeps spinning, it's your location that isn't accurate enough for Prime.

    Either go outside so you can get an better GPS fix, or buy another phone.

    Unlike Redacted (and possibly Pogo/HPWU, I don't know), Prime requires a far more accurate location before it loads.

  • mortuusmortuus ✭✭✭✭✭

    what phone do u even got ?

  • Can't get into Prime until I'm 200 yards down the road, so it's not just a case of stepping outside. I have a Moto one vision, son has a Note9 and also can't get in.

  • kittysukittysu ✭✭✭

    I have had this problem with Prime since the beginning. It says "location acquired", but the globe spins for minutes until I give up and force close the app. It happens outside in areas clear of trees and buildings, so I find it hard to believe it is GPS related. It happens on 2 different phones I use (depending if I am focussed on Ingress or playing both Harry Potter and Ingress at the same time) and also on my husband's phone, all different brands.

    Yet on holiday, using same phones and same MiFi/SIM to provide data, in an area with poorer signal, Prime usually loaded straight away, even in a house that gave other apps difficulties with GPS.

  • starwortstarwort ✭✭✭✭✭

    I was recently on holiday in France, and often would get the spinning globe for 30-60 seconds after 'Location acquired', and occasionally for several minutes.

    This never happens in my home area, or indeed anywhere I've so far been in UK. Here, 'Location acquired' means just a few seconds of the globe animation before the map view appears. (Of course, it does take two minutes of looking at a blank screen to get to that point on my phone, but that's another matter.)

    In indoor areas with bad or no GPS, the globe spins forever with 'Scanning to acquire user location'. It doesn't pretend the location was acquired and then carry on spinning.

  • jontebulajontebula ✭✭✭✭✭

    Did you set GPS high or max? I know connection works bad with Prime and Niantic must update the app to fix we always can use Prime when connection atomatically switch from 4G to lower connection.

  • MamaginMamagin ✭✭
    edited August 2019

    GPS is fine for every other GPS using app. It says 'location acquired' which would suggest that GPS has found the location!

    It isn't a fault with my phone, as I said in a following comment it won't open for my son and his super duper phone either.

  • I am having the same "spinny screen" issue as many others on here.

    It's not my phone. (Pixel XL 2) I have tried everything. Clear Cache, turn location off/on again, even deleted and reinstalled the app.

    Some days i get in after two or three attempts. Others i give up after 6 or 7 attempts.

    It's not the area i am in either, as i have tried in town centres, fields, on the toilet at home, and it's the same experience.

    @Niantic please look into this issue as i am one of thousands of people on the verge of quitting the game all together if this persists.

    If Prime is faulty, why bin redacted before fixing these bugs?

  • Screenshots of GPS status in location when I've tried to use Prime.

    And this is what I get.....and nothing else.

    I used prime the whole weekend in Gothenburg, and apart from the anomaly debacle, it worked well and I enjoyed the experience. But the fact that you can't rely on it working in a reasonable sized town with good reception isn't acceptable.

    @NianticBrian @NianticBC

  • Since the latest update my issue seems to have been resolved and the problem locations load consistently 1st time.

  • jontebulajontebula ✭✭✭✭✭

    For me Prime start tutorial lots of time. I must restart Prime 4-6 time.

Sign In or Register to comment.