Glyph hacking still hangs in the command channel 2.29.2

Imagine, you have an event where you need to make 1000 glyph hacks to get a gold medal. So off you go and start Glyph hacking. It takes time to do that many glyph hacks, so you don’t want to waste any time. The first 10 or so run smoothly, then you glyph hack and request a key, what happens? Nothing, the scanner just hangs there “command channel open”.

You wait 10 seconds and glyph more again. Ah now comes the glyphs, annoying, but Ok.

Next Portal, Glyph Hack, request key, again after 10 seconds the “command channel open” message is still there so you Glyph more. After another 10 seconds still no glyphs, so you Glyph more again. You resist the urge to throw your phone into the trash, it’s not your phones fault. Other players have this problem as well, albeit not always at the same time as you.

You Glyph more again, oh wonder! the glyph sequence comes.

Next Portal, after 4 or 6 attempts at glyphing more and still being stuck in the command channel you force close the App and restart. The App restarts immediately, so no problem with a data connection. You start the glyph hack and everything runs great. Until, 10 glyphs later, perhaps I will smash my phone into the ground and never play another mobile phone game again.

This event is just driving me nuts, I can cope with the difficulty of the challenge, but not with the App actively preventing me from trying to complete it. Heat Sinks and multi hacks in the store? Forget them, sometimes you need 5 minutes to get the Glyph hack to actually provide you with glyphs!

FIX THE GLYPH HACKING PROBLEM IN PRIME!!!!!

Device: Apple iPhone 8 (Android users also have this problem)

OS: IOS 12.3..1

App Version : 2.29.2-ecc17158

Tagged:

Comments

  • jontebulajontebula ✭✭✭

    I hope Niantic fix the bug soon!

  • mortuusmortuus ✭✭✭✭

    I dont understand how glyph can still have issues in prime when redacted is around the corner to retire for good ? all years old scanner never issues glyph hacking unless u fail one but thats because u didnt pay attention.. but technical issues and bugs is very serious still a problem :(

  • roclarroclar ✭✭

    To be fair, this also happened in Redacted. If there's any interruption in the data connection both clients will have issues.

  • It feels like Prime might be more susceptible to a poor data connection. Perhaps it makes more re-use of connections, or a different networking library uses different options (with regards to hard timeouts and the like). My experience of the problem is definitely worse in Prime than it was in REDACTED.

  • I don't understand Niantic, this bug isn't new,

    They should have made Aurora challenge after correcting it to underline that's now it works flowlessly.

    Whereas right now, it's just forcing player to use a bugged feature.

  • iFrankmansiFrankmans ✭✭✭

    This bug has been around since the introduction of Prime.

    I must say it was even worse in the beginning.

    But nevertheless it should be fixed (and with this challenge it was even more annoying).

  • BarthaxBarthax ✭✭✭
    edited August 22

    Agree the bug remains in 2.29. I can usually get past it by using (yet another) command in the command channel (use MORE or LESS when stuck).

  • If this actually has any effect at all then it's not reliable. It feels like more of a placebo action, more likely TCP retry timers in the background happening to have expired.

  • jontebulajontebula ✭✭✭

    Prime works bad or bug when we have lower connection than 4G i hope Niantic fix the problem soon for Prime.

  • So, here's the scenario. Redacted goes away, Anomaly play time and Glyph hacking still doesn't work! Great!

    Since this problem has been present in Prime since very early on it is idiotic that it has not been resolved yet. It is not like this is a rare circumstance that occurs to only a few people. Everyone glyph hacks, at least occasionally.

  • kireankirean ✭✭

    Still a problem for me.

  • This has been happening for me (iOS version, build 2.33.1-8a221209) relatively frequently, possibly as much as one glyph attempt in five. It just gets stuck in "command mode". Phone shows good signal during this period, though there could be connection problems that don't show in the signal bar icon.

  • I'm seeing 3 forms of glyph hangs

    1. command channel hangs. To find out how long, I've waited as long as 15 minutes... it will never continue. But pressing anywhere on the screen will recover and continue on to glyphing. Interestingly the hack time is considered as when you started the command channel, so after waiting 15 minutes, and then doing the glyph, you're able to immediately do another hack.
    2. command channel hangs, but pressing anywhere does not recover. but pressing 'X' aborts the hack, and ingress is still usable. you can try glyphing again. Both this and (1) happen alot, but are not fatal and just an annoyance.
    3. hang occurs during command channel but freezes Prime completely. you can not exit. Going out of ingress and back in results in a black screen.

    I'm not sure the fatal hang is command channel specific, but because I see a similar fatal hang while just viewing in the scanner. But when glyphing, its always happened to me in the command channel.

    During mission day, the fatal hang occurred on each mission, so roughly every 6 hacks. And the other 2 hangs more frequently, but not a big deal.

    Redacted hung alot too (memory leak in stats), but start time was fast (7 seconds). I'd like Prime to load faster. I spend a lot of my time Prime time, in the load screen.

  • Happens all the time for me on both android and ios. So annoying I may just quit this game.

    Give us redacted back?

  • It never happened with old client/redacted for me. It is not a connection issue at all I think. I suspect it is a bug where it is stuck in drawing state all the time so it thinks you are doing input when you are in fact done drawing.

  • Jo0LzJo0Lz ✭✭✭✭

    Still an issue in the current client. At first I thought the order of commands mattered, but they don’t.

    this bug is annoying as hell.

  • All 3 hangs I mentioned 4 messages back still occur in 2.35.2

    I've also encountered a 4th type of glyph issue - NoRetriesError.

    Its not a hang, but requires Prime be shutdown/restarted before you can hack again.

  • GrogyanGrogyan ✭✭✭
    edited November 12

    Bug has been present since Glyphing was first introduced in Classic Ingress.


    Only a server upgrade will assist in getting it fixed for Prime

  • Jo0LzJo0Lz ✭✭✭✭
    edited November 12

    Nonsense. I’ve never had these issues with redacted, maybe a few times. Didn’t have any issues with glyphing the first few weeks after redacted was retired.

    right now, it’s really time consuming to go around 16 portals and glyph for keys, sometimes you can hack half a day without the issue, then it’s there all of a sudden.

    a server upgrade to display a random predefined string of pictures? :/

  • Keep in mind there are 3 different types of glyphing hangs. I'm not aware of any in redacted, but each will need different changes.

    The fatal hang that requires a restart is the most time consuming for me. While I do missions, its about every 3rd mission.

    Its not glyphing specific though... it can hang at any time. But when your main action is hacking, thats the most likely place for the hang to occur.

    The other 2 are not fatal. Press 'X' and Prime will recover. Its annoying and happens very frequently but does not take that much time to recover.

  • GrogyanGrogyan ✭✭✭

    The hang in the command channel is one thing that that has been around a very long time. Even if you didn't get it often, it was there.


    The other glyphing issues, i'm still having on a daily basis

  • chookchook ✭✭
    edited November 12

    The guy is correct redacted had no issues.

    With regards to prime... This is still happening... it happens all the time... and i mean more often then not. I sit on a portal at work and glyph alot.

    This happens on iPhone and Android.

    This happens whether it is mobile data or WiFi. It has been going on since prime was released.

    This is video i converted to a gif... only about 14 seconds but you can see it lagging... i send the command glyphs twice as sometimes sending another command glyph kicks it off (I can't be sure of this, it may be random but it seems to) and please bear in mind that this LAG sometimes goes on for Minutes.

    At the First Saturday before last i was playing in the rain and it was doing it constantly for minutes... i was very wet and yes i can see the funny side of it.... but when you are having competitions for badges such as the "Aurora Glyph Challenge" (Glyph hack unique portals during the August 2019 Aurora Global Challnege) it becomes and absolute joke! Luckily Redacted was not gone at that stage so we had that to fall back on.

    Please note that this is not effecting everyone. But it is happening to many... Niantic please look into... it is so irritating and it is real!


    I am happy to provide as many video/gifs as needed until Niantic acknowledge this. Feel free to contact me if you need a subject tester.. as it does not effect all agents..... so i am told by other agents.

  • GrogyanGrogyan ✭✭✭

    @chook I cannot comment on why you likely did not see the glyph hanging in the command screen in Redacted.

    It happened to me quite a lot, on every device I owned in Classic/Redacted. S4, S5, S7 and my S9+

    In Prime, I see the same amount of hanging as I did with Classic/Redacted

  • chookchook ✭✭
    edited November 13

    @Grogyan Yea i am not sure, i never noticed it. You are probably more perceptive than me however... in anycase this prime glyph lag sometimes goes for minutes... Normal hack is always instant.

Sign In or Register to comment.