Ingress Prime bugs in priority order

I've been using Prime every day for the past few months and the following is my list of the top 5 bugs with the Prime client in order of most annoying / gamebreaking / infuriating to least. For context, I play on an iPhone 8 Plus with the latest stable iOS (currently 12.4). I'm only looking at bugs and not feature parity.



1. Getting stuck on "Command Channel Open" while glyph hacking.


Despite the release notes for 2.27 claiming to have fixed this issue, I still seem to be getting stuck at the same place with the same frequency. It's (almost?) never on the first hack after restarting the client, but usually it takes around 5-8 hacks before it starts getting stuck. Once it starts getting stuck it will almost always continue to get stuck on subsequent hacks, with the frequency of getting stuck and the duration of being stuck increasing as time goes on until the client is restarted.


Once stuck, the only way to get unstuck is to input commands or else just draw randomly every few seconds. Eventually (sometimes after 1+ minutes) the hack will proceed normally. If no further input is given after getting stuck, you will be stuck presumably until the end of time (have tested this out to several minutes).


Now for some anecdotes that should be taken with a grain of salt. When sitting in one place hacking the same few portals I don't seem to get stuck. When I don't input any commands I don't seem to get stuck as often. I often get stuck when I'm walking around interacting with many different portals in a row.


This bug alone has wasted many hours of my time over the past few months, and time is your most valuable and limited resource when playing Ingress. This bug is well deserving of the #1 spot.



2. Interactions are no longer triggered when pressing UI elements, instead triggering when the press is released


I'm treating this change, introduced in 2.27, as a bug (hopefully it is?) because it seems to be causing issues throughout the app. This has quickly become a source of frustration when using Prime since the new UI update. Since now where your finger is when you release is important when it didn't used to be, additional precision is required. Here's some examples of areas impacted by this bug:

  1. I'm constantly running into "portal out of range" messages now when attempting to hack a portal that I can just barely reach. It used to be that if you could press the hack button you were able to hack the portal. Now that's no longer the case. This is especially noticeable when swiping the hack button to glyph hack, hack-request-key, or hack-no-key.
  2. When long-pressing Fire to charge, moving your finger even very slightly cancels the action.
  3. Swiping the main button into a menu now can press buttons in that menu when you release your finger. Like when swiping into inventory, if your swipe ends on the manage button you're instantly mass-recycling without meaning to.


3. Medals / missions / keys displaying blank images until the app is reinstalled


I reinstalled Prime yesterday because my 4 most recent medals were showing up as blank. They were also blank when I got the popup letting me know I earned a new medal, which was pretty disappointing as I like to screenshot my gold+ medals earned. So my onyx Recharger, platinum Trekker/Translator, and gold Myriad Hack medals were all just blank hexagons. My profile loaded properly after reinstalling but now it looks like this (again):



This is also a big problem with keys, as the images are a good way for me to quickly locate the correct key when I'm trying to find one in my inventory or in a key locker. But when some/all the images are blank it's pretty difficult.



4. Linking issues


When linking, the view of the destination portal is often incorrect or takes a long time to load in the links and fields around the portal you're linking to. This often makes it difficult to know if you're linking to the right portal if you aren't 100% sure. When throwing multiple links, it will sometimes show already-linked portals as eligible for additional links. And finally it won't cut you off when you reach the outgoing link limit, leading you to try linking when you can't.



5. UI buttons disappearing


Sometimes buttons disappear in the inventory menu. Notably the "Manage" button for key lockers and capsules will disappear, and the "Recycle" button within the mass-recycling mode for resonators/weapons/etc will disappear. I can get the "Recycle" button to reliably disappear by hacking a portal, then quickly going into inventory then mass-recycle mode around the same time that the box listing everything you got from hacking is displayed. To restore the button you must exit out of the inventory menu, tap to close the hack results box, then try again. But sometimes this bug occurs even without hack results on screen.

Comments

  • bridgerdierbridgerdier ✭✭✭

    You forgot the most glaring problems: Network and GPS handling

  • KhatreKhatre ✭✭✭✭

    1 and 3 seems to be network problem.

    I never have those unless data reception is crappy.


    Freezes and time out are the most problematic problems in prime

  • starwortstarwort ✭✭✭

    It used to be that if you could press the hack button you were able to hack the portal.


    It has always been possible to get "portal out of range" as a hack result while the hack button was activated, even when Ingress 1.x was current.

  • starwortstarwort ✭✭✭

    Anyway your priority list is way different from mine. Mine would be something like...

    1. Frequent hangs and crashes
    2. Long startup times on some phones (2 minutes on mine)
    3. Weird effects when you view/recharge remote portals:
      1. Portal keys not staying in alphabetical order
      2. Off-centre view when returning to the main scanner
      3. Phantom portals, links and/or fields appearing (though I haven't seen that for a while now)


  • slalomzslalomz ✭✭✭
    edited July 31

    I actually never really have GPS problems, unless you're talking about the speedlock, which while annoying doesn't affect me much since I mostly play on foot or else just leave the app open. Those might be phone related if you're experiencing constant network/GPS problems.


    I don't think so. I often have full or almost full bars of LTE and I am consistently getting stuck glyph hacking. It happens everywhere I play.


    That hasn't been my experience with Prime, I was not often running into that problem before the UI update that changed when actions happened relative to your presses. I've also played more on Prime than I ever did on Redacted (just started playing this year), so I was unaware this was a problem on the old Scanner.


    My Prime doesn't hang or crash very often. Maybe because I'm restarting the app so often due to the "Command Channel Open" bug it doesn't stay up long enough to crash. Startup time for me is around 13 seconds so I'm pretty happy with that. Can't say I've seen 3a occur, although I do occasionally get the off-center view when returning from a remote portal - requiring a restart. While irritating that only happens to me maybe once every two weeks while I get stuck on "Command Channel Open" probably literally 20-40 times a day on average.

  • jontebulajontebula ✭✭✭

    If i get no data connection i must restart the app. I cant hack when i have connection again. Loading portals when i have the app long time in backround dont work. I dont see portals. I must restart Prime.

  • bridgerdierbridgerdier ✭✭✭

    That's exactly what I'm talking about. The whole behavior when returning from the background is abysmal. Both the GPS jumping and triggering speedlock and the very slow update. I once opened Prime on a train while sitting at a station. Train sat there for 2+ minutes. The map did load, portals/links/fields did not. The same situation in Redacted usually loads within seconds. Or else there are actions that trigger instant reloads

  • #2 is definitely annoying! I used to be able to play with a lot less precision and still be able to make the app execute my expected actions. Now if I try to do a swipe action, half of the time it will just stop at showing the swipe options and I'd have to do an extra tap to finally make the app do what I want it to

  • slalomzslalomz ✭✭✭

    Ah I actually ran into the speedlock issue today, funny enough. I was getting blank error messages in Prime despite sitting still after driving to a remote portal. Switched to Redacted and all of a sudden I could deploy and hack.

  • I cannot use Prime any more, on login all I get is this screen

    Had to uninstall recently to reset a badge.

    Have tried uninstalling again but still get this screen. I can still play redacted. But have not used that for months now. Need to get Prime back!

  • I cannot go to settings due to problem above!

  • "Manage" button being greyed out on Capsules. Might be the same bug that stops interaction with a key (once you've tapped to go into the key/portal specific screen). I have to restart Prime once an hour or more due to this.

Sign In or Register to comment.