Ingress is not supported

DSktrDSktr ✭✭✭✭
edited March 22 in Report a Bug

A popup with "ingress is not supported on this device configuration" appears. I can understand if Ingress don't like my custom Android 13 on my Samsung S8,but i also got Xiaomi Mi Mix 2 on stock Android 9 with closed bootloader and it also tells the same.

Can i have some clarification about what's going on?

NB PokemonGo works well,even GooglePay works,but not Ingress.

Post edited by DSktr on
11 votes

Active · Last Updated



  • I've started getting the same error. It was fine a few hours ago.

    Xiaomi Mi 11 Ultra, MIUI 14.

  • Same problem here.

    Phone Honor Play Android 9

  • Mesmo problema aqui com meu note 8 pro xiaomi

  • pawelkipawelki ✭✭

    Samsung Galaxy S8 with stock Android 9 - same problem.

  • IAmQbIAmQb ✭✭
    edited March 22

    Same problem.

    Xiaomi Mi 8, Lineage OS 21 (=Android 14) with GAPPS.

    I cancelled my C.O.R.E. subscription for now even though I hope I can play again soon and resubscribe.

    Edit: This last paragraph sounded way more entitled and like making a thread than I intended. Anyways I am very happy that I get to play again and I of course reactivated my subscription.

    Post edited by IAmQb on
  • N87tqtN87tqt ✭✭

    I tried with A Galaxy s7, a poco f1, a Samsung A15. Everywhere this message appears out of the blue, where i was fine on my main device just yesterday.

    I hope this will be solved soon while keeping our active streaks. Which i am warned about via push notifications but can't do **** about :(

  • Also seen on OnePlus 5 running the stock Android 10 image, no root, no bootloader unlock

  • Also having this issue as of this afternoon. I assumed it was because I'm running GrapheneOS, but as far as Ingress can tell, this is just Android. No root, locked bootloader, etc.

  • GrogyanGrogyan ✭✭✭✭✭

    Galaxy S8 is a really, really old device.

    Why not get something more modern from just a couple of years ago?

  • cnargcnarg ✭✭

    GrapheneOS on Pixel 7a - no root - also not working anymore, played just some hours ago.

  • VashiruVashiru ✭✭

    Just started seeing the same problem on a OnePlus 8T. Stock Android 12, not rooted, no unlocked bootloader. Was working fine last weekend and even on Tuesday still.

  • N87tqtN87tqt ✭✭

    SafetyNet checks out as well. Weird.

  • Issue seems resolved, just logged in. Looked like a server side Play Integrity issue.

  • GrogyanGrogyan ✭✭✭✭✭

    SafetyNet is deprecated.

    This isn't a reason though for the Ingress team not to give a heads up forewarning about old devices being no longer supported

    Hopefully thus can be fixed ASAP for all affected players

  • IAmQbIAmQb ✭✭

    It's working again, thanks to the team for the speedy fix!

  • If you were seeing an Ingress is not supported on this device configuration error message earlier today, can you please share your device's Google Play Integrity verdict information so that we can investigate further? For steps on how to do this, please see this Google documentation:

    First, enable the Play Store's developer options on the device. On the Play Store app, tap your profile icon and then tap Settings. Open the About menu and tap the row labeled Play Store version seven times to unlock developer mode.

    Then, to generate a verdict from an Android device, open the Play Store app. Tap your profile icon and then tap Settings. Open the General menu and then tap Developer options. In Play Integrity settings, tap Check integrity to generate a verdict.

    If you aren't seeing Labels: [MEETS_BASIC_INTEGRITY, MEETS_DEVICE_INTEGRITY, MEETS_STRONG_INTEGRITY] then this means your device does not meet Google's integrity checks. This can happen if you're using a device with an unlocked bootloader, if there's malware on your device, or if you did not download the official Ingress app from the Google Play Store.

  • N87tqtN87tqt ✭✭
    edited March 23


    Build fingerprint: Xiaomi/beryllium/beryllium:10/QKQ1.190828.002/V12.0.3.0.QEJMIXM:user/release-keys

    Brand: Xiaomi

    Device: beryllium

    Model: POCOPHONE F1


    Don't punish users for running modified Roms and using devices in a more secure and sustainable way.

    Don't make changes of this kind without telling people.

  • InvestigateXMInvestigateXM ✭✭✭✭✭


    Build fingerprint: OnePlus/OnePlus8Pro/OnePlus8Pro:13/TQ3A.230901.001/f71d0ea59a:userdebug/release-keys

    Brand: OnePlus

    Device: OnePlus8Pro

    Model: IN2023

    Was not able to enter Ingress earlier today, likely because of an unrooted custom ROM (LineageOS). Please don't make me revert to stock OS, it sucks for Oneplus :(

  • DSktrDSktr ✭✭✭✭


    Build fingerprint: samsung/dreamltexx/dreamlte:8.0.0/R16NW/G950FXXU1CRC7:user/release-keys

    Brand: samsung

    Device: dreamlte

    Model: SM-G950F

    TestId: dGVzdGluZy0yMWRlMzNiMy02YWIxLTRhZWUtODQ2Mi0zMzU5YmY2Njc3MDI=

  • DSktrDSktr ✭✭✭✭


    Build fingerprint: Xiaomi/chiron/chiron:9/PKQ1.190118.001/V12.0.1.0.PDEMIXM:user/release-keys

    Brand: Xiaomi

    Device: chiron

    Model: Mi MIX 2

    TestId: dGVzdGluZy0wYzIzZWViYi0xM2FiLTQ0ZjAtOGZjNC01NTI0NDY1MWM5ZDY=

  • DSktrDSktr ✭✭✭✭

    Actually there is an app called Play Integrity api checker,which does the same:)

  • N87tqtN87tqt ✭✭

    So i can confirm it works again, BUT my 327 day hackstreak is gone and i want it back.

    I claim "force majeure" and hope for leniency on the side of Niantic.


    Build fingerprint: HONOR/COR-L29/HWCOR:9/HUAWEICOR-L29/

    Brand: HONOR

    Device: HWCOR

    Model: COR-L29

    TestId: dGVzdGluZy00NjJlODUxNS1mMmM3LTRlMDYtODI5OS1kOGNhYmM5N2ZjN2U=

    Device ist not rooted and running stock OS.

    Portal scanning is not supported as well btw, despite having a supposedly supported Chipset.

  • I had the same error message but after a restart the phone finished installing a system update to feb 2024 security patch and ingress started to work again, so maybe try to force a system update. My phone is a POCO X4 pro with android 13.

  • MillopaiMillopai ✭✭✭

    Mine is showing an input error. I played normally hours ago.

    Ingress is not compatible with this device configuration

    TO TRY


    Build fingerprint: motorola/penang_g/penang:14/U1TPS34.29-37-2-1/8dd47-b430fa:user/release-keys

    Brand: motorola

    Device: penang

    Model: moto g53 5G

  • Please note that we do not support rooted or jailbroken devices, as published in our Niantic Terms of Service, which were last updated on May 8, 2023.

    3.4 Eligibility and Account Registration

    If you want to use certain Services, you will have to create an account with us (an "Account"), and you will also need access to a supported mobile phone and an Internet connection. The help centers at Niantic Game and App Resources contain a list of supported devices. We do not support rooted or jailbroken devices.


    Build fingerprint: Xiaomi/fuxi/fuxi:14/UKQ1.230804.001/V816.0.7.0.UMCCNXM:user/release-keys

    Brand: Xiaomi

    Device: fuxi

    Model: 2211133C


  • N87tqtN87tqt ✭✭

    How do you define "jailbroken"? Is it something like limera1n on an iphone? Is it a simple different OS on your android device and an unlocked bootloader? The entire ToS is bad if you say "root is not supported". People buy devices to own them. To fix shotcomings of the manufacturer OS like ads, tracking, functional problems, root is a legitimate way to make a device last longer and work better. this has to change asap. Stop discriminating power users that know what they want and what they do. Let people **** themselfes in the foot if they prefer to do so.

  • DSktrDSktr ✭✭✭✭
    edited March 24

    Rooted phones aren't supported because of cheaters,despite there are ways to have even stock rom and cheat software.

    Also there are lots of supported phones and custom roms aren't officially supported just because who knows what is changed in such roms not by official manufacturer but by developer. I mean,custom roms lead to too many device variants,much harder to trace bug.

    From the other side i see there are devices with hardware check (eg Google Titan chip) also affected. Google pay haven't problems,and play integrity possibly haven't - only Ingress app. That means (imo) this bug is Niantic-side not users-side.

    Usually a person who can install custom rom and probably root - has at least basic and device integrity passed,btw.

  • DSktrDSktr ✭✭✭✭

    Mentioned above specs:

    Minimum resolution of 480x800 pixels

    Minimum of 512MB RAM (this needs to be corrected,i don't think 512 is enough for Android 8+,Google services and Ingress app,i'd bet 1.5gb is bare minimum,but it will be too laggy)

    ARMv6+ processor (actually ARM7&ARM8,no libs for ARM6,and idk about x86)

    GPU that supports OpenGL ES 3.0 (connected with above,i don't know any ARM6 with such GPU)

    Strong Wi-Fi or network connection


    Android 8+

    Rooted devices are not supported

    Beta or Preview versions are not supported

    * Also Play integrity test should be passed,at least two green marks in "yasnac" test or "play integrity test"(easy to use - just grab app in store and check),Ingress can work a bit with cts profile mismatch/failed basic integrity,but only a day+-.

Sign In or Register to comment.