[2.125.1] Storage permissions were removed, Scans and using photos from storage impossible

InvestigateXMInvestigateXM ✭✭✭✭✭
edited September 23 in Report a Bug

After updating today, I was greeted with this message trying to scan a portal. I was surprised as I didn't remove any permissions for Ingress, and after checking against 2.124.2, it seems like the newest update removed the storage permission for Ingress, making it impossible to enable and to scan.



Crucially, this is a different bug compared to the other one where previously eligible phone suddenly had the "Scan Portal" button vanish.


This also seems to affect trying to upload a photo you previously took for Submissions or for a new portal picture with the following message:

The title of the bug report has been adjusted accordingly.

Post edited by InvestigateXM on
16 votes

Completed · Last Updated

This is fixed in Ingress 2.125.2, which is starting to roll out now. Thank you for your patience.



  • InvestigateXMInvestigateXM ✭✭✭✭✭

    After downgrading, these are the permissions asked for when first performing a scan:

    After that, scanning works like normal. As these permissions have been removed from the newest update, scans cannot be made anymore.

  • GrogyanGrogyan ✭✭✭✭✭

    Yeah, definitely not working anymore on my device

    Device: Galaxy S21 Ultra Exynos 2100

    OS: Android 13

    Tried cleaning the app data,

    Didn’t work

    No more scanning until this is resolved. For me this is really important, as I'm often in areas where I am not usually, and do scans to prove I was there.

  • InvestigateXMInvestigateXM ✭✭✭✭✭
    edited September 23

    This also seems to affect trying to upload a photo you previously took for Submissions or for a new portal picture with the following message:

    The bug report has been edited accordingly.

  • 업데이트만 하면 문제생기는 게임- 이제 망하기 시작 한건가...

  • HopeaKotkaHopeaKotka ✭✭✭✭
    edited September 24

    It may be also that upload later is not working as storage permission may be required when trying to upload later.

    Haven't tried this as I have not updated to latest version.

  • AlbioreAlbiore ✭✭
    edited September 24

    Same problem on galaxy s23 ultra, Android 13.8.27

  • After applying the latest update last night I also have the problem with Google Pixel Pro 7. Do we know if Niantec are working on a fix?

  • Same issue. Portal scanning stared working for a few days on Galaxy S23 Ultra, but after updating last night cannot scan anymore due to the missing camera and storage permissions.

  • I have the same permissions bug when using "Existing Photo" for a portal nomination. Pixel 4a 5g/Android 13

  • Same problem! Please fix!

  • Got me too, on a Samsung Galaxy S22.

    I have camera permissions on but I can't upload a photo.

  • simurghsimurgh ✭✭✭

    Hope this fix gets prioritized. Update killed scanning for me and partner, and we're traveling right now, part of the fun of which is to get access to some new portals we haven't scanned before.

  • DSktrDSktr ✭✭✭✭

    Have storage and camera permissions,but no scan.

    2.125.1,Samsung S8,custom rom. The same with Samsung J7-17 with stock. Both devices are ARCore compatible and had scan before.

  • Same issue here on newest app version. Galaxy Z Fold 5/Android 13.

  • Same issue. Cannot load photos for new portals. Samsung A54 5G.

  • Same issue on a Samsung Note 20 Ultra. Found the issue as I was at a new park out of town and would have really liked to have been able to scan the 40 or so new to me portals.

  • I am a computer programmer and currently dealing with AWS Cloud infrastructure as the team leader.

    When we have an issue that results in any sort of client impact, we have an incident report written about it.

    As part of that report we have a topic called "The 5 Whys".

    As many of us are paying for the product via the Core subscription model, I think we are entitled to know just what the hell is going on?

    The nature of the errors are not a design issue or a gameplay issue. This sort of thing is pretty fundamental to mobile games. And shouldn't have been altered without a LOT of reviewing of the changes.

    How did a reviewer allow these changes to go through to production? Or does everyone just push and hope for the best.

  • But ... PURELY guesswork .... why WOULD storage permissions be removed?

    Probably because the app has been changed to direct/realtime upload? No "Upload later"? No uploads for existing images. All direct image processing.

    And somehow, someone failed to understand that when you release software you have to have tests.

    Well ... we're the testers ... simply rewind the changes and re-release things.

    Oh, whilst you're fixing this, the UI issues where the portal name, the current AP total, and the level progress bar are suddenly all occupying the same space on the scanner ... What platforms was this code working on?

    Surely there can be SOME sort of official statement about the way in which the bug count is increasing with each release?

    A lot of us out here do this work for a living. We would REALLY love to help out! UX/UI designers, QA, DevOps workflows, global cloud / region experts, there is pretty much always going to be SOMEONE to cover something Niantic need. Just please ask for help!

  • Where is the QC department of Nia? That is the second serious problem with Ingress at the same time.

    There must be some statement about the process of QC from the management.

    Strange, strange ....

  • Same problem.

    Samsung galaxy A51

  • M42M42 ✭✭✭

    Please be before next weekend @NianticBrian , it's a long weekend here and I want to go on an Ingress road trip to do some unique Scout Controlling..

    JK's, no rush, as long as it's fixed.

  • Use the Wayfarer app until it’s fixed.

  • Fix is rolling out to all Android agents now in version 2.125.2, thank you.

  • Moto one macro.

    No puedo escanear en ingress, pero si en Pokémon ... plop

  • Guess what's back, back again.

    Scans are back, tell a friend.

  • Xiaomi Mi 11t

    1 mes sin escanear

  • Wil this gain scout or scout controller points? I don't think so. Not a fix.

  • GrogyanGrogyan ✭✭✭✭✭

    Permissions, appears to be fixed, but haven't had time to do a scan yet with the hotfix

    Device: Galaxy S21 Ultra Exynos 2100

    OS: Android 13

  • Google Pixel 6 Pro. Got scout controller on a couple of portals today and submitted a load for a new nature park. All working fine.

    Just wished they all got saved automatically and no need to wait for a menu. Scan -> storage and you upload when you need as the upload speed is atrocious and so wait until home.

Sign In or Register to comment.