Browser performance

I am on firefox and the site does seem to respond very bad. When I am typing I often receive a lag of a few seconds. Seems to happen with threads which a rea a tad bit longer but also when typing in a normal tempo. Do other browsers experience the same?

Comments

  • I’m another reporting having a terrible time typing comments in iOS. The upshot is that at least now I know I’m not the only one.

  • SvardodSvardod ✭✭

    Definitely something going ‘overboard’ with the “Leave a comment box”.

    Just entering a thread heats my iPhone so it is very hot to the touch.

    Lag is insane on typing with me several words ahead before it catches up. Just had a 15 second lag spike. This is nearly impossible to use.

  • starwortstarwort ✭✭

    It's pretty bad. On my laptop I can type a whole sentence and then have to wait about 30 seconds for the whole thing to show up at once. On my work desktop it's slightly quicker, preferring to display the text a few words at a time, occasionally making me wait maybe 10 seconds for a sentence to appear.

    At this point I would really love a plain HTML textbox to type in. It was never this slow on Reddit.

  • Jo0LzJo0Lz ✭✭✭

    Typing in the comment box on mobile is just plain impossible. I write comments in the notes app and the paste them in the forums. My guess is this is because of the font they’re using. This really should be fixed, using the forums on mobile is terrible.

  • I'm also using Firefox and I have the same lag issue while typing as well. It's frustrating and I imagine that it can be off-putting to many. Hopefully the issue can be fixed soon.

  • @Ravenston I have also reported this

  • It's working fine for me on MacOS using Chrome but on iOS keystrokes have a delay of around 15 seconds per tap (or small group of taps). I have no idea what would cause that.

  • mortuusmortuus ✭✭✭

    no website lags this much on the internet like this one.... firefox and its a pain to type...

  • The comment field only works in Chrome, all other browsers suffer from severe lag. The rich editor is using code that was optimised in V8 but in no other script compiler. Either that, or the polyfill is broken.

    My recommendation: replace the rich text editor with one that can be turned off and uses plain text instead. Ideally so that users can write in Markdown if the rich text editor is turned off.

    Oh yeah, and test in more than just Chrome, guys. Just some friendly advice from one front end developer to another.

Sign In or Register to comment.