shop logs in with wrong account and no possibility to change

Unable to buy anything as its impossible to pay. The in scanner shop does not select the same account the scanner was opened with.

Thats a hilarious and dangerous error nia.

Even worse, it is not possible to tell the shop to choose the right account to withdraw from. It insists of the wrong one, or it doesnt show the buy cmu at all or just fails with a scanner communication error.

It cant under any circumstances be legal that the shop wants to withdraw from a different account as one is signed in.

Tagged:
1
1 votes

Intended - Not a Bug · Last Updated

Comments

  • InvestigateXMInvestigateXM ✭✭✭✭✭

    This is not an Ingress bug, but an Android limitation. The account used for payment is always the first one that was added to the phone, being the Main account. You can remove the account until the right account gets choosen by Play Store, then you can re-add all the accounts you have removed.

  • THXIIOI38THXIIOI38 ✭✭
    edited July 29

    Thats hilarious 😱 esp as the first on device has any ingress, pogo or else nia account attached.

    So,

    • Why its not clearly mentioned in ingress?


    • Why can i see google credits in my account (and not in first)
    • Why google redeems playcredits into non usability?

    • Is it just a myth from niantic because i can not see any google warning?


    ps why is this forum fupped with those inserts?

  • @THXIIOI38 Ingress only sends a request to Google Play, so if you're using multiple Google Accounts on your device, my understanding is that what you're referring to depends on what Google Account you chose to sign into Google Play with and not what Google Account you chose to sign into Ingress with. This is working as designed.

  • It seems you as well fall for a niantic myth out of bad coding.

    The google playstore beneath all other google services are logged in as my account. It is the backup device of my mum. She installed hers as first long time ago but since then all all actions and downloads took place on my second account on device.

    Again, why i can even redeem play credits and those are correctly showing on my account if they should practically be unusable. Thats apparently a complete nonsense.

  • THXIIOI38THXIIOI38 ✭✭
    edited July 29

    so basically the money my aunty gave me now completely is in vain because i redeemed play credits not on my mums account i promised to not log into?

    😭

  • Hey @THXIIOI38! Google Play uses the account you used to install the app rather than the first Google account added to the phone. This may also happen if someone hit update when they were logged in to the wrong account. A workaround for this issue is to uninstall Ingress, log in to the Play Store with the right account (verify this has the credits you want to use), and reinstall Ingress from this account.

  • i already tried that several times but that does not work. Ingress even was initially installed under my account. Playstore, gmail and the other google services as well are logged into my account. I even tried all clear all data, all cache, uninstall then reboot and reinstall and it just wont help at all. As google does no refunds the present from my aunty simply is lost 😞

Sign In or Register to comment.