Nomination does not allow moving to correct location/snaps to current location

Took a portal picture and supporting picture and saved to phone. Moved to spot within 10km (more like 5km) to a place with wifi and attempted to submit nomination. Initial screen allowed me to appropriately place marker for portal, but after typing title and description, the location showed as my current location, not the corrected portal location.

I have tried stopping/starting the app, rebooting the phone, moving the POI to a closer location (not correct, but just testing) that was ~300m away and all still reproduced the problem where the location map showed as my current location, not the "where I placed the marker".

On IOS 15.3, iPhone XR, ingress version 2.89.1, connected to Wi-Fi.

Did the ability to submit nominations while not standing atop the portal change? The last time I attempted a portal submission when not in front of the POI was back in December 2021, so this may have been happening for a while (i.e. I may have missed an announcement about a change).

1
1 votes

Intended - Not a Bug · Last Updated

Comments

  • mortuusmortuus ✭✭✭✭✭

    u need to post location edit appeal on the wayfarer forums now.

  • That's unfortunate. I would rather not submit something that shows where my couch is (i.e. where I am when I submit the nomination). I would suspect that the nomination would instantly get rejected for a mismatched location before any action is taken on a forum post.

    Guess I will have to detour to a coffee shop with free Wi-Fi to submit from now on. Do you know if there's a plan to correct this rather unfriendly multi-step process?

  • @JenTil if you're trying to submit a new Portal nomination, you need to take the Portal photo, supporting photo, and finish the nomination at that location; however, you do not need to upload the nomination at that time while you're on a mobile data connection. Starting with the last Ingress update, after you finish entering your nomination info and reason, tap UPLOAD LATER to upload your Portal nomination later. You can upload your Portal nomination when you're on Wi-Fi at home, whether that's 10km away or further.

  • AzhreiaAzhreia ✭✭✭✭✭

    @NianticBrian this seems to be an issue with iPhones. I have a local with an iPhone who is experiencing the same issue. They cannot move the marker to the correct location, it snaps back to their current location.

    @RobberySl8ter has the same issue.

  • Ugh. Well, that's doable, I guess in terms of getting to a spot with wifi. But it's not necessarily comfortable to have to do all of the other stuff when there is inclement weather, excess people, impatient family members not wanting to wait for my fussing with the phone, etc. I prefer the old way where I could just make the quick snapshots and move on, but I guess times are changing and I either adapt or give up submitting. Thanks for letting me know.

  • I have also run into this bug today on my iphone. It was working fine 3 days ago when i subbed a couple of portals i took pics of some time ago, and I was onto my fourth sub today before i noticed the issue. 3 subs withdrawn, 1 exitted! I did the latest update over a week ago, and this was not occurring at that time.

    Like JenTil, I also have non playing family that i might be wandering with, so i will take pics now to be subbed from home when i can take my time. I also prefer to spend my time that I can play playing, rather than subbing, which can be done from home. or when i have nominations available. Please dont make us choose between play or sub.

    Its also important to note that where the pin drops when you are standing at a potential is not always where you really are due to GPS drift, so even if you did intend this (OMG, please no), you will cause more inaccuracies by not allowing us to correct drift.

  • @NianticBrian So i tried subbing some portals today,and i had issues where the marker showed in the wrong place, (middle of building, instead of beside it) and I was unable to correct it due to this BUG. I'm sure you dont mean for us to submit int eh wrong place and need to send an edit in after. Its always betetr to put the nomination in for the correct place when submitting. Accuracy and not clogging queues is important. When will this be resolved? It only seems to be affecting iphone players, which doesn't sound intended.

  • This is ridiculous. Why has this been done and also why no warning?? We all don’t have the luxury of standing nominating something, and often there are times when we need to do research on something and simply taking a supporting photo isn’t enough. I’ve had this issue previously and had 3 nominations rejected because they were on my house, not only does this give away my personal address to those with malicious intentions, and trust me there are many, it just makes the whole process even more difficult than it already is! Currently we can still move the pin some distance in Pokémon Go but are you to remove this distance too? And probably without any warning that we should watch for pin pinging back to the wrong location. What exactly does doing this achieve except annoying an already angry player base. The worse idea of the worst ideas already out there. Change it back.

  • InvestigateXMInvestigateXM ✭✭✭✭✭

    On Android, I have just submitted a portal from home about 2.5km away from me, and it shows up on Wayfarer at the right location, as expected.

  • AnnaNass42AnnaNass42 ✭✭
    edited February 14

    Same here. Problem for me started on feb 10th.. 14:24 cet location ok, 18:12 cet incorrect location (times are taken from submition confirmation emails). AFAI can tell, neither Ingress nor phone updated in the hours between, it just stopped working on same versions.. -.-

    Ingress spits this out:

    Parent of RectTransform is being set with parent property. Consider using the SetParent method instead, with the worldPositionStays argument set to false. This will retain local orientation and scale rather than world orientation and scale, which can prevent common UI scaling issues.

    Sadly it didn't provide the full stack for error. :/

    Post edited by AnnaNass42 on
  • @NianticBrian I concur with this. And I also tried to submit a portal today which is less than 5km away and it allowed me to select the location at first but when the screen for checking all the information came, the location was my current location and not the one that I had selected. I am using an iphone SE 2020. So indeed, the bug persists.

    My version is 2.89.1


    I just submitted 3 portals about 2 weeks ago or so and it worked back then.

  • I am also using an Iphone 2020 SE, with Ingress version 2.89.1. I’m unable to adjust the pin even slightly when nominating a wayspot. It always snaps back to my exact position when I opened the nomination page, which is rarely exactly correct. This is game breaking to me. I’ve seen many other people report the same issue, where before we were able to remote submit up to 25km.

  • Agent739107Agent739107 ✭✭
    edited February 15

    @NianticBrian

    Hello.

    I have had the same problem for 5 days(2022-02-10).

    The information about the environment where the problem occurred is,...

    # iPhone SE (2020)

    # iOS 15.3.1

    # ingres 2.89.1-b73a4b24

    and

    # iPad (6th generation)

    # iPadOS 15.3.1

    # ingres 2.89.1-b73a4b24


    However, in that environment, this problem has not occurred.

    # iPhone SE (2016)

    # iOS 14.8.1

    # ingres 2.89.1-b73a4b24


    I took a video of the situation where this problem occurred.

    I want to upload it to a place where only certain people can see it because it contains personal information, is there a good way to do this?

    Post edited by Agent739107 on
  • iFrankmansiFrankmans ✭✭✭✭

    Having the same issue now.

    This can by no means be intentional, not even allowing it to move 1 m in the submission screen.

    If this is what it is gonna be a lot of people will just stop submitting all together, everytime you get a weird rejection you will have to get back to the exact location to re-submit!?

  • The nomination location is appearing wrong too start with. Just started the process and it has me in the wrong location some way off in the next street. I move pin to location of waypoint and it snaps back to the wrong location altogether. This is a bug and NOT intentional. It’s stops you nominating even when at the location in person.

  • Sorry, but I fail to see how submit later will help with incorrect pin that we cannot set properly as it won't stick to where it was set and insteads hopps back to agent location. ATM even if submiting at the location, we cannot adjust for the gps drift.

    So should we just be quiet and abandon submitions altogether? Or are you (Niantic) going to mark this as bug and actually fix it? 🤔

  • Whoab0tWhoab0t ✭✭✭
    edited February 16

    Since when has this been the case? Is this new? What sense does that make? If I can remotely submit from home, but can't remotely submit somewhere, and then upload somewhere with a strong cell signal or wifi? I had remotely submitted portals only a week ago, and uploaded them later with no issue.

    I tried to submit six wayspots in areas with spotty cell signal ("strong" enough to capture, but not strong enough to load the map to finish the submission), and had to go somewhere with better cell signal to finish it only to be surprised when my marker was where I remotely submitted. Am I going to get those back? This is clearly a bug.

    Pokemon Go doesn't have this issue.

  • This seems to only be an issue for IOS. Android works fine. Has anyone from Niantics actually read our posts ??

  • BeVewyVewyQwietBeVewyVewyQwiet ✭✭✭
    edited February 16

    This is also preventing my from submitting things in the correct locations. Have tried multiple restarts. It is definitely a bug as it is a dramatic change from the past two years of submitting over 200 accepted portals.

    Iphone 12 mini

    latest ingress version 2.89.1

  • I also experienced this bug--attempted two submissions, the furthest of which was 2.5km from my location at the time of submittal. Was able to drag the location pin to the nomination location, but when finalizing the nominations, the pin was at my location at the time.

    iPhone XR

    iOs 15.3

    Ingress 2.89.1


    @NianticBrian

  • Seems to be fixed? Just been through the process. Map took a little time to load on confirmation screen however the pin was correct.

  • daawgdaawg ✭✭✭

    I’m not thrilled with the lack of communication from NIA but yes indeed it seems to be working again, for which I’m obviously delighted. It baffles me tho, how this bug happened and got fixed.

  • worked as usual today iphone se2020. experienced the discribed issue in the last week

  • Circling back to this to say that the issue does appear to be resolved. I can submit from locations not atop the POI and adjust the location: I submitted a bunch of locations from both a few meters and a few kms away two days ago.

    There may still be a minor issue where two POIs I submitted that were fairly close to each other (but properly placed on the nominations map) now show up to be at the same spot when I look at the "contribution" via the wayfarer page. But if one of those (eventually) gets rejected for being "too close", I can live with that as the overall process is working again. Thanks!

  • Not fixed. Not if you get your nomination all ready and select “upload later,” because then instead of using the location where you created the nomination, it uses the location where you are uploading.

    CAUTION!!! This problem DOXES your location AND your nominations will not go through so you can’t request an edit, later. All downside, no upside.

Sign In or Register to comment.