Drone not moving properly / displayed drone location "resets" to earlier portal

Starting since around 1-2 days ago I've noticed some odd drone behaviour.

  1. After moving a drone, attempting to hack will give an error message saying the portal is out of range. Exiting and reentering the drone menu will show that it is still at the previous portal, and needs to be moved again.
  2. Entering the drone menu will show that it is on the wrong portal, usually at the location before the most recent move. Attempting to move it to a new portal that's within range of both the displayed location and "correct" location will display the moving animation but attempting to hack will produce the same out of range error. Exiting and reentering the drone menu after this failure will show it at the proper location.

This started occurring after I got a scanner communication error from the drone menu after attempting to move it, and it also occurs when I tried reinstalling the game on a different phone, so this does not appear to be due to the device.

Device model: Xiaomi Poco NFC X3

Android version: 11 RKQ1.200826.002

Ingress version: 2.84.1

Connection: 4G/5G/Wi-fi

Tagged:
3
3 votes

New Report · Last Updated

Comments

  • Amendment to #2 above: I don't think it's actually "resetting" to its earlier position, it seems like the game thinks the drone is in two places at once and each position can be moved separately, but only one position can be hacked.

    eg. It seems like if I move the drone from Portal A to Portal B then get an error while hacking, reopening the drone menu shows me as back at Portal A and if I move it to Portal C instead, the next error causes the drone position to be at B due to the earlier phantom move. Going to test this by trying to move in opposite directions every time I get the error and see if I really do end up in two places at once.

  • Update to the above: The game really does appear to think the drone is in two completely different locations at once, and intermittently decides to switch between which position can be controlled. I recorded a video of it occurring but it's too large to upload, so screenshots from it are below.

    Initial position after opening drone menu, this drone was able to hack this portal after the last move:

    Attempting to move and hack a different portal:

    The move succeeds but hacking produces an error message:

    Closing and reopening drone menu:

    Game has switched to the drone's alternate position and move timer is at zero again:

    Moved alternate position to a different portal:

    Alternate position can be hacked:

    For reference, this is how far apart the two drone positions currently are:


    It seems that:

    1. The drone is in two places at once and each location can be moved independently
    2. Only one position can be controlled and used for hacking at a time
    3. After a move, the game can randomly changes its mind about which location is correct, which prevents the now "incorrect" location from being hacked but will allow immediate movement and hacking at the alternate location

    I haven't tested if both drones show up on the drone layer and/or can be returned by attacks.

  • This exact issue started for me just yesterday. Everything you described. Had not experienced that before and came here to see if anyone else did. Mine had been working just fine until yesterday. I tried reinstalling Ingress, but didn't help.

    Specs:

    Device model: iPhone 6

    iOS version: 14.8.1

    Ingress version: 2.84.1-8d91d1d0

    Connection: 4G/Wi-fi

  • Apparently there was another player known to have 2 drones and reported it multiple times but kept getting told it wasn't a bug so they just gave up and enjoyed the double hack chances. I made this thread as a new report because I didn't know it was a double drone bug and assumed it was some kind of movement/position bug but after some testing, it seems to be a double drone bug since you can double your hacks when the drone "switches".

  • kittysukittysu ✭✭✭

    The number of times I have had a scanner communication error - and the most odd thing that has happened is that my drone appears to have returned to me when it has not actually. And a restart of the app fixes that glitch. I'd love to be able to experiment with this scenario!

  • Interesting. However, unfortunately, my double drone doesn't double hack. After trying this more, the first drone that appears for me never successfully hacks (neither director or glyph). It always shows the error "Portal not in range".

    Then I close that screen and start the drone again. It goes to the second one and I am able to hack either way with that one.

    If I was able to double hack, I probably wouldn't complain. lol

    It's just more annoying the hassle of going back and forth as well as both drones skipping back a few portals every now and then.

Sign In or Register to comment.