Crash during Portal Scan and Upload Portal Scans never ends

HopeaKotkaHopeaKotka ✭✭✭
edited December 2020 in Report a Bug

https://community.ingress.com/en/discussion/12675/crash-during-portal-scan-and-scan-upload-failed-with-promise-finally-threw-an-exception

With version 2.60.2 App tries to send a corrupted Portal Scan forever, no "Scan Upload Failed" message shown.

  1. Ingress crashed during portal scan recording.
  2. Start Ingress again
  3. Go Setting -> "Upload Portal Scans".
  4. App tries to send Portal Scans and animation rotates forever (See picture below).
  5. Continue Portal Scanning -> All subsequent Scans are uploaded ok with "Upload Now".
  6. Delete corrupted Portal Scan from Phone
  7. Go Settings -> "Upload Portal Scans "
  8. -> Remaining Portal Scans are now uploaded ok



Today there were about 5-6 crashes during Portal Scan recording and 2 scans were lost.


Samsung S8
Android 9
2.60.2  
Tagged:
12
12 votes

New Report · Last Updated

Comments

  • ToxoplasmollyToxoplasmolly ✭✭✭✭✭

    I ran into a similar issue the other day (Android 11, Pixel 4, Prime 2.59). I tapped "Start", waited 45 minutes while the spinning triangle sat there spinning, finally noticed that my stats were not going up, and restarted Prime. I tapped "Start", again, and scans started uploading as expected.

    I might have noticed the lack of progress sooner if the experience was not so user hostile.

  • I have the same issue on ios 14.2

  • Hello. Is anyone else having this issue when scanning portals? I am on an iPhone 8+ with the current ingress version.


    essentially, after I scan the portal and click either “upload now” or “upload later”, instead of configuring things in the background, it gets frozen on the decoding screen... often resulting in app crashes.


    I’ve tried restarting the app, scanning other portals, and even deleting and re installing the app, nothing seems to help.


    attached photo shows what I’m talking about.


    also I apologize if this was posted in the incorrect place, first time posting on the forum


  • CliffMCliffM ✭✭✭✭✭

    All the time - a good 30-35% of the time for me. It's intensely frustrating. I tried scanning portals this morning - 6 portals total. I scanned the first one 3 times before it went through, restarting the app each time. I was able to scan the next 4 portals without issue, but when I went to scan the last one, I gave up, after attempting to scan it 4 times. I scanned it so many times since it was a volatile and I wanted the sweet extra credit. I never got credit for it though, because I gave up. I then gave up scanning for the morning.

    I am motivated to do scans now, but I just can't a lot of the time, because of this bug. I would attempt 40-50 each outing, but with this bug I barely get through 10 most outings.

    I have over 1500 Scout points, so I am not just blowing smoke - I have been doing this a fair bit. (I am sure there are many who have done more)

  • The bug report page may be more appropriate.

    I'm going to comment on it here.


    I'm also suffering from freezing of portal scan with iPhone8.

    The error occurs after about four or five portal scans.


    It's been happening since about the end of November.


    I have, so far.

    I've tried restarting the Ingress app after using the Cache Clean app.

    or restarting the app twice.

    If I use the cache clean app and restart the Ingress app, or restart the Ingress app twice, I can get the portal scan to work again.


    If you restart the Ingress app twice, you can do the portal scan again, though it will freeze after 4 or 5 more portal scans.

    The EOS protocol increased the number of scans,

    but I'm not making any progress with the portal scan at all.


    I think it's because I've upgraded to iOS 14.2 and I don't have good control over the cache.

    The Ingress app has been updated twice, but the freezing still hasn't improved.


    iPhone8 

    iOS14.2

    Ingress 2.59.2-2.60.2-2.61.3


    @NianticBrian

    I hope the development team at Niantic will fix this problem soon.

  • Do you guys also have problems with uploading scans later?

  • TimoVVTimoVV ✭✭
    edited December 2020

    Upload later does not seem to work for me. I've been trying for three days now to upload a few scans but it keeps loading forever and eventually it crashes. It only uploaded 3 scans on Sunday, but there's more.

  • Yes, i have it and also have problems uploading right after scan. Im on 2.61.3 update, Scanner seldom crashes while uploading. Uploading later from Settings page taking very long time, its like nothing is loaded because didnt got any notifications.

  • There are numerous bugs with scanning. (on android11)

    uploading later often crashed and took a few hours, so I've stopped doing that, except sometimes 'now' queues things to be uploaded later anyway. my home wifi is slow/unreliable, so later is not a good option.

    when I'm in a low signal area i would like upload later to work better... it still takes a few minutes of struggling for it to get enough signal to defer the upload. Couldnt it work closer to offline?

    It would be nice of photos and nominations also had an upload later. They seem to take extra long when combined with scanning.

    I lose enough scans and quota that I always scan twice, assuming some scans will be lost.

    The 15 seconds, up from 5, is not great...it makes for a longer window/chance of a failure during scan and upload. scanner failures of one sort or another cause much of the lose. If the scanner stops working and I restart, uploads that were in progress are sometimes lost. I do a lot of scanner restarts.. its like I'm **** my onyx restarter badge.

    For example, you scan, and while uploading in low signal, ingress signs out. Its subtle... a little persons head appears in top left of notifcation bar. After that, nothing will work... hacks, viewing new portals as you walk etc. So you need to restart. If you had a nomination or photo upload in progress, its lost. Sometimes the scanner just abruptly exits to the home screen without help.

    There are numerous bugs where restarting the scanner is how you fix it. Portal scan uploads that are in progress may be lost. And the scan quota... which is not a big deal, now that we have lots of quota, but you get credit for fewer scans than you use quota for.

    A recent issue I'm seeing is a scan starts, you go to stop, and it goes back to scan start.. scan was lost like you didnt start it. Happens several times a day starting around version 2.60

  • iOS 14.2 (18B92)

    Ingress Prime 2.61.3

    scanner keeps reiterating over scanned images (N of 310)

    crashes after a couple of iterations

    reinstalled, to no avail.

    several futile attempts over a couple of weeks. (Upload later)

    Hope this helps.

  • 対応ソフト未対応の携帯電話なので、

    スキャン自体出来ない

  • Is there still no fix for this?

  • After scanning a portal, it will not save or upload. I have tried it with both my iPhone and iPad with no success. After the failure, I have to close out ingress prime and reopen it. I have successfully uploaded scans in the past, but have not been able to for the last month.

  • When I scan a portal, it will not save or upload. I haven’t been able to successfully scan a portal for over a month. When I attempt it, it also freezes the game so that I have to reload the game

  • One more month and this is still an issue for me. Tried it today with the new 2.65.1 version. What should I do? Should I clear all my waiting uploads and lose them all or wait another month for a fix? Been 3 months now. I am not keen on losing them as scanning in winter has not been enjoyable.

    Anyone else still have this issue and what have you done to fix it?

  • On February 18 I did post a solution how to delete corrupted scan from phone, but it seems that NIA did not accept that post and it never got published here. Maybe the solution have a risk to cause more harm if not done correctly.

    Hopefully NIA can provide a fix soon. For example checking and deleting corrupted scans from phone before sending scans to NIA server.

Sign In or Register to comment.