Visual Glitches

Whilst playing I have noticed the following visual glitches:

  1. All text suddenly changes to block characters
  2. Graphics switch out with other (random) graphics
  3. Screen goes black

All three are remedied by closing the app and reopening it. It doesn't seem to affect any of the actual functionality, just the graphics. I have a number of example screenshots, which I will add below.

The only gameplay I have done of late is portal scanning, so my theory is that the visual glitches might be due to some kind of caching issue or overflow issue with the graphics and fonts.

Firstly, version details:

Ingress version: 2.55.1-e9974a5f

Phone: Samsung Galaxy S10 (SM-G973F)

Android Version: 10

This was also happening on the previous version of Ingress, sorry I didn't catch the version number. I had hoped these issues would be fixed in the latest version, but they have persisted.


Now I will start with my favourite visual glitch so far:

I found it hilarious seeing 'The ****' appear on the in-game store (it looks like my reaction when I saw this!). I recognised the image from a local portal that I had recently scanned. I have a video showing this glitch in action, but I chose not to share it here as it includes my home location.

Random graphic replacing the Avenir Shard Challenge badge image. This isn't a portal photo, but probably some stock Ingress testing image?

Here the Field Test: Hexathlon badge image was replaced with a random portal image. I haven't even scanned this portal, as it is far beyond the 5km radius I am allowed to travel from home (as it was for that player too - whom did scan the portal, but that's a whole other legal matter lol)

The Explorer badge was replaced with a black square. This isn't even a portal image, probably another Niantic test image?

And here the font just randomly switches over to this blocky look. The game still functions, but it makes it difficult to know what the names of things are. It's not always consistent either, as you can see, sometimes things become blocky whereas other texts do not turn to blocks. The block still appear to represent the proper letters/characters, but they are much more chunkier.

Lastly, sometimes the whole screen will just go black. I haven't bothered to take a screenshot of this, but it has happened a few times.

Again, restarting the app has resolved the issues immediately every time. I feel like scanning portals is causing these issues, usually after a number of them (not just one or two, but at least 10 or 20).

Would be interested in hearing if anybody else is seeing these glitches. Cheers.

Comments

  • HopeaKotkaHopeaKotka ✭✭✭
    edited September 19

    Yes, did also notice this kind of behaviour after doing Portal Scans since release 2.55.1:

    https://community.ingress.com/en/discussion/12041/graphics-gets-mixed-up-with-latest-2-55-1-after-several-portals-scans-done

  • PerringaidenPerringaiden ✭✭✭✭✭

    I wanted to add one small to this that has persisted since beta:

    • When using a power cube, the accent flare around the Use button appears mostly off screen at the bottom left of the display.
  • oscarc1oscarc1 ✭✭✭✭

    Thank you @HopeaKotka, sorry I didn't see your thread earlier.

    Had another visual glitch today. The portal image changed to a skewed perspective of my scanner, as I moved so did the avatar within the portal image. It was kind of cool lol


  • I'm looking at this visual glitch and thinking: Wouldn't it be amazing if the data from Portal Scans were used to show a 3D rendering of the portal and the portal's flame and resonators?

  • Yesterday after doing a bunch of portal scans, I restarted the app and it started up normally (with the globe, etc), except then the screen was completely black. I could still tap on the blackness and get the "ping" animation, but there were no portals and no UI elements. I restarted my phone and the result was the same. On one occasion I could see the nearby portals, but as if viewed from a great distance. Since there was no UI, I couldn't upload my scans.

    Starting Ingress on another phone (same account) worked normally.

    Finally, I tried erasing my user data under Android settings. (Previously, there was 1.01 GB of user data.) That fixed the issue, but of course I lost all of my pending portal scans. 😫

    PIxel 3, Android 11, Ingress 2.55.1-e9974a5f

  • oscarc1oscarc1 ✭✭✭✭

    Almost forgot to post this gem


  • I also had the Block text thing happen after scanning a portal, but today I also experienced the animated Portal Pic glitch and took a screen record of it. After exiting the Portal details the map screen was totally black. Restart fixed it.

Sign In or Register to comment.